Bug 319631 - [RFE] memtest86+ allow runtime configuration of serial port/options
[RFE] memtest86+ allow runtime configuration of serial port/options
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: memtest86+ (Show other bugs)
4.9
All Linux
low Severity low
: ---
: ---
Assigned To: Anton Arapov
qe-baseos-daemons
: FutureFeature, Reopened
Depends On:
Blocks: 344791
  Show dependency treegraph
 
Reported: 2007-10-04 21:36 EDT by Issue Tracker
Modified: 2014-06-18 04:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-27 10:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch series providing the requested functionality (3.70 KB, application/x-gzip)
2007-10-17 12:27 EDT, Michal Schmidt
no flags Details

  None (edit)
Description Issue Tracker 2007-10-04 21:36:57 EDT
Escalated to Bugzilla from IssueTracker
Comment 1 Issue Tracker 2007-10-04 21:36:59 EDT
We would like the ability to run memtest86+ on serial consoles reliably.  However the serial console device and baud rate are compile time options (set in config.h and serial.h) so we are having to compile many versions and configure the appropriate one.  Currently we are building the following.

Making the serial device and baudrate a parameter on the grub.conf line would be the most flexible solution IMHO.

memtest86+.vga
memtest86+.9600.ttyS1
memtest86+.9600.ttyS0
memtest86+.19200.ttyS1
memtest86+.19200.ttyS0
memtest86+.115200.ttyS1
memtest86+.115200.ttyS0

To use ttyS1, you need to do the following.

$ diff -u serial.h.ttyS0 serial.h.ttyS1 
--- serial.h.ttyS0      2007-10-01 11:12:41.000000000 -0400
+++ serial.h.ttyS1      2007-10-01 11:13:07.000000000 -0400
@@ -136,8 +136,8 @@
  */
 
 #include "io.h"
-#define serial_echo_outb(v,a) outb((v),(a)+0x3f8)
-#define serial_echo_inb(a)    inb((a)+0x3f8)
+#define serial_echo_outb(v,a) outb((v),(a)+0x2f8)
+#define serial_echo_inb(a)    inb((a)+0x2f8)
 #define BOTH_EMPTY (UART_LSR_TEMT | UART_LSR_THRE)
 /* Wait for transmitter & holding register to empty */
 #define WAIT_FOR_XMITR \\

This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 133769
Comment 2 Michal Schmidt 2007-10-17 12:27:06 EDT
Created attachment 230041 [details]
patch series providing the requested functionality

This is a patch series I sent upstream. It adds boot command line parsing to
memtest86+. The parameter for serial console configuration is similar to
Linux's "console=...". E.g.:

title memtest
	root (hd0,0)
	kernel /boot/memtest.bin console=ttyS1,115200

Awaiting response from upstream.
Comment 3 Warren Togami 2007-10-17 14:04:55 EDT
I added this to F8's memtest86+ so it gets some test exposure.
Comment 4 Michal Schmidt 2007-12-12 05:38:18 EST
Upstream accepted the patches. There hasn't been a new upstream release yet. The
version in Fedora 8 (memtest86+-1.70-4.fc8) has the patches included. Installing
it on RHEL4 should work.

Could you test it and see if it works satisfactorily?

If so, I'd suggest closing this bug. If the F8 package works without problems on
RHEL4, there's little point in backporting the patches to the older version of
memtest86+.
Comment 5 Stewart Smith 2007-12-12 15:40:12 EST
tested on 9600 and 19200 baud systems. works well, thanks.

Is a postinstall script planned which calls /sbin/new-memtest-pkg ?
Comment 6 Warren Togami 2007-12-12 16:27:38 EST
> If so, I'd suggest closing this bug. If the F8 package works without problems on
> RHEL4, there's little point in backporting the patches to the older version of
> memtest86+.

The request for RHEL4 was not to backport, but instead to upgrade it to the
latest upstream version since it really has nothing to do with the base OS (no
risk to do it).

But I guess the request was not picked up.
Comment 7 Frank Hirtz 2007-12-12 16:54:16 EST
It appears that there was a bit of confusion on this one. We'd be fine with an
uprev since as Warren notes, it's not really connected to the Base OS and thus
should introduce no risk.
Comment 8 Warren Togami 2007-12-12 17:07:03 EST
If it happens in RHEL4, please be sure it happens in RHEL5 in Bug #344791 too so
it isn't seen as a "regression" by customers.
Comment 9 RHEL Product and Program Management 2008-02-01 14:01:57 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 11 RHEL Product and Program Management 2008-10-31 12:36:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 12 Anton Arapov 2010-04-08 06:39:49 EDT
requires memtest86+ package update to the version 2.00 or newer.

Note You need to log in before you can comment on or make changes to this bug.