Bug 344791 - [RFE] memtest86+ allow runtime configuration of serial port/options
[RFE] memtest86+ allow runtime configuration of serial port/options
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: memtest86+ (Show other bugs)
5.6
All Linux
low Severity low
: ---
: ---
Assigned To: Anton Arapov
qe-baseos-daemons
: FutureFeature
Depends On: 319631
Blocks: 554476
  Show dependency treegraph
 
Reported: 2007-10-21 21:52 EDT by Warren Togami
Modified: 2014-06-18 04:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-10 13:03:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-10-21 21:52:36 EDT
This would be exactly identical to Bug #319631 for RHEL4.7, except compiled with
a different gcc version.  Does this mean that we have to do QA twice?

+++ This bug was initially created as a clone of Bug #319631 +++

Escalated to Bugzilla from IssueTracker

-- Additional comment from tao@redhat.com on 2007-10-04 21:36 EST --
We would like the ability to run memtest86+ on serial consoles reliably. 
However the serial console device and baud rate are compile time options (set in
config.h and serial.h) so we are having to compile many versions and configure
the appropriate one.  Currently we are building the following.

Making the serial device and baudrate a parameter on the grub.conf line would be
the most flexible solution IMHO.

memtest86+.vga
memtest86+.9600.ttyS1
memtest86+.9600.ttyS0
memtest86+.19200.ttyS1
memtest86+.19200.ttyS0
memtest86+.115200.ttyS1
memtest86+.115200.ttyS0

To use ttyS1, you need to do the following.

$ diff -u serial.h.ttyS0 serial.h.ttyS1 
--- serial.h.ttyS0      2007-10-01 11:12:41.000000000 -0400
+++ serial.h.ttyS1      2007-10-01 11:13:07.000000000 -0400
@@ -136,8 +136,8 @@
  */
 
 #include "io.h"
-#define serial_echo_outb(v,a) outb((v),(a)+0x3f8)
-#define serial_echo_inb(a)    inb((a)+0x3f8)
+#define serial_echo_outb(v,a) outb((v),(a)+0x2f8)
+#define serial_echo_inb(a)    inb((a)+0x2f8)
 #define BOTH_EMPTY (UART_LSR_TEMT | UART_LSR_THRE)
 /* Wait for transmitter & holding register to empty */
 #define WAIT_FOR_XMITR \\

This event sent from IssueTracker by tdunnon  [SEG - Feature Request]
 issue 133769

-- Additional comment from mschmidt@redhat.com on 2007-10-17 12:27 EST --
Created an attachment (id=230041)
patch series providing the requested functionality

This is a patch series I sent upstream. It adds boot command line parsing to
memtest86+. The parameter for serial console configuration is similar to
Linux's "console=...". E.g.:

title memtest
	root (hd0,0)
	kernel /boot/memtest.bin console=ttyS1,115200

Awaiting response from upstream.

-- Additional comment from wtogami@redhat.com on 2007-10-17 14:04 EST --
I added this to F8's memtest86+ so it gets some test exposure.
Comment 1 RHEL Product and Program Management 2008-07-21 19:08:53 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 RHEL Product and Program Management 2009-03-26 13:03:36 EDT
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 8 Anton Arapov 2010-04-08 06:39:13 EDT
requires memtest86+ package update to the version 2.00 or newer.
Comment 10 RHEL Product and Program Management 2010-08-09 15:18:06 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 11 Anton Arapov 2010-08-10 13:03:47 EDT
The bug is likely to be rejected for the whole EL5 lifetime, because it doesn't conform to any criteria. Safe to close.

Note You need to log in before you can comment on or make changes to this bug.