Bug 319771 - [hts-5.1.1][ppc64][storage][EL4-U6] - Storage Test for hts is FAIL
[hts-5.1.1][ppc64][storage][EL4-U6] - Storage Test for hts is FAIL
Status: CLOSED WORKSFORME
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
ppc64 Linux
low Severity low
: ---
: ---
Assigned To: YangKun
:
: 316951 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 02:10 EDT by Satyabrata Maitra
Modified: 2008-09-12 12:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-12 12:19:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ppc64-storage-.log files (20.00 KB, application/x-tar)
2007-10-05 02:10 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-10-05 02:10:43 EDT
Description of problem:
When tested for Storage for hts-5.1.1 on ppc64 on EL4-U6, Its FAIL. .log files are
attached with this bug.

Version-Release number of selected component (if applicable):
hts-5.1.1

How reproducible:
Tried Once, and reproduced.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Its FAIL

Expected results:
It should PASS

Additional info:
Comment 1 Satyabrata Maitra 2007-10-05 02:10:43 EDT
Created attachment 217091 [details]
ppc64-storage-.log files
Comment 2 Greg Nichols 2007-10-05 10:28:52 EDT
The error is:

Error: hda is currently in use by LVM.
It cannot be tested. You may need to reinstall.
...finished running ./storage.py, exit code=1

I believe this is fixed in R2.

Comment 3 YangKun 2007-10-08 03:38:48 EDT
Hi Satyabrata,

I checked the error log you attached, seems there are no swap partitions
available in the system(or the swap partitions are not enabled). Please notice
that "valid" swap partitions are required to successfully run the STORAGE test.
So could you please make sure the swap partitions(at least one swap partition)
do exist on "hda" and you can see it in "/proc/swaps", then could you please run
the STORAGE test again and see if this issue still exists ?

Thanks very much!
-YK
Comment 4 Satyabrata Maitra 2007-10-08 03:47:06 EDT
Hi YK
ah! got it! Actualy I performed this test on reserved systems remotely. So, if
to test it, I need to retest it on another system. May you pls inform  me if I
can see swap partitions from terminal and if not present, how can i create it
from the terminal. Does it need to restart the system after it created? Please
inform. All I do, I have to do remotely. So, pls inform if it is possible or not. :)
Thanks
Comment 5 YangKun 2007-10-08 04:20:49 EDT
> Hi YK
> ah! got it! Actualy I performed this test on reserved systems remotely. So, if
> to test it, I need to retest it on another system. May you pls inform  me if I

to check if swap partitions are enabled is easy, check the file "/proc/swaps",
for example:
----------------------------------------------------------------------------------
[kun@yk ~]$ cat /proc/swaps 
Filename                                Type            Size    Used    Priority
/dev/sda3                               partition       2096472 0       -1
[kun@yk ~]$ 
----------------------------------------------------------------------------------(In


if this file is empty, then no swap partitions in the system or they may not be
enabled.

> can see swap partitions from terminal and if not present, how can i create it

if the system does have a swap partition(let's say /dev/hda3), but this swap is
not enabled, you can enable it by running:
    # swapon /dev/hda3

if the system does not have swap partitions and does have some spare space, use
fdisk to create a swap partition, then run "partprobe", then run "swapon" to
enable it .

if the system does not have swap partitions and does not have spare space
neither, but does have some useless partitions(e.g. /dev/hda4 is ext3 , is
mounted on "/data/" and contains no system files and no useful info), then we
can change these useless partitions into swap partitions:
    1) unmount them first
    2) "mkswap" to convert to swap partitions
    3) "swapon" to enable

but if the system does not have swap partitions and does not have spare space
and does not have useless partitions neither. then you have to re-install the
system.
 

> from the terminal. Does it need to restart the system after it created? Please

no, once you enabled the swap partitions, you don't need to reboot. but please
make sure you can see the swap in /proc/swaps every time before you run the
storage test(better to add the swap info into /etc/fstab).

> inform. All I do, I have to do remotely. So, pls inform if it is possible or
not. :)
> Thanks

Comment 6 YangKun 2007-10-08 04:31:51 EDT
*** Bug 316951 has been marked as a duplicate of this bug. ***
Comment 7 Satyabrata Maitra 2007-10-09 02:56:09 EDT
hmmm! got it! ok, I will perform this test once again following your instructions. 
Thanks a lot really!
:)
Comment 8 YangKun 2007-10-09 05:42:20 EDT
great! then I'll wait for your upcoming results :)
Comment 9 Satyabrata Maitra 2007-10-16 07:30:52 EDT
Hi YK
I am extremely sorry, still I did not get any ppc system after booking among
reserved systems. As soon as I get it, I will retest it. I am not having any ppc
system with physical access thus I can install tree and test it! :(. Please bear
with me. Really don't know where all ppc reserved systems gone!
Comment 11 YangKun 2008-09-11 21:25:59 EDT
Hi Satyabrata,

It's been quite a long time. do you have any update ? can this bug be closed/verified?

Thanks
-YK

Note You need to log in before you can comment on or make changes to this bug.