Bug 320291 - autotools action conflicts
autotools action conflicts
Status: CLOSED DUPLICATE of bug 252013
Product: Fedora
Classification: Fedora
Component: eclipse-cdt (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Johnston
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 11:46 EDT by Andrew Overholt
Modified: 2008-02-12 16:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-12 16:02:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Overholt 2007-10-05 11:46:29 EDT
I don't really know what this means, but when I start eclipse on the command
line, I get the following error messages.  I'm running eclipse-cdt-4.0.0-7 and I
highly doubt this has changed in 4.0.1 so don't tell me to try that one out :P

!ENTRY org.eclipse.ui.workbench 2 0 2007-10-05 11:28:57.650
!MESSAGE A handler conflict occurred.  This may disable some commands.
!SUBENTRY 1 org.eclipse.ui.workbench 2 0 2007-10-05 11:28:57.651
!MESSAGE Conflict for
'AUTOGEN:::com.redhat.eclipse.cdt.autotools.actionSets/com.redhat.eclipse.cdt.autotools.actions.invokeAutoconf':
HandlerActivation(commandId=AUTOGEN:::com.redhat.eclipse.cdt.autotools.actionSets/com.redhat.eclipse.cdt.autotools.actions.invokeAutoconf,
       
handler=ActionDelegateHandlerProxy(null,com.redhat.eclipse.cdt.autotools.actions.InvokeAutomakeAction),
       
expression=AndExpression(ActionSetExpression(com.redhat.eclipse.cdt.autotools.actionSets,org.eclipse.ui.internal.WorkbenchWindow@7ae6d),WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7ae6d)),sourcePriority=16640)
HandlerActivation(commandId=AUTOGEN:::com.redhat.eclipse.cdt.autotools.actionSets/com.redhat.eclipse.cdt.autotools.actions.invokeAutoconf,
       
handler=ActionDelegateHandlerProxy(null,com.redhat.eclipse.cdt.autotools.actions.InvokeAutoconfAction),
       
expression=AndExpression(ActionSetExpression(com.redhat.eclipse.cdt.autotools.actionSets,org.eclipse.ui.internal.WorkbenchWindow@7ae6d),WorkbenchWindowExpression(org.eclipse.ui.internal.WorkbenchWindow@7ae6d)),sourcePriority=16640)
Comment 1 Jeff Johnston 2007-10-05 12:21:15 EDT
I believe I have found the problem.  The InvokeAutoconf and InvokeAutomake
actions had the same id for their extensions.  A fix has been checked in.
Comment 2 Jeff Johnston 2008-02-12 16:02:12 EST

*** This bug has been marked as a duplicate of 252013 ***

Note You need to log in before you can comment on or make changes to this bug.