Bug 321501 - F8t3 no keyboard models, layouts and variants in gnome-keyboards-properties
F8t3 no keyboard models, layouts and variants in gnome-keyboards-properties
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: control-center (Show other bugs)
rawhide
i386 Linux
low Severity high
: ---
: ---
Assigned To: Control Center Maintainer
Fedora Extras Quality Assurance
:
: 322341 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-06 14:24 EDT by Adam Pribyl
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 09:09:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2007-10-06 14:24:34 EDT
Description of problem:
In F8t3 there are not layouts and keyboard variants to select in
gnome-keyboard-properties.

Version-Release number of selected component (if applicable):
2.20.0-1.fc8

How reproducible:
Allways

Steps to Reproduce:
1. Systenm -> Preferences -> Hardware -> Keyboard -> Layouts
2. try to select keyboard model (Unknown by default) - there is nothing
3. +Add Layouts or Variants  - the lists are empty
  
Actual results:
It efectively prevents usage of any other keyboard layout than US.
I consider this as major loss of functionality.

Expected results:
At least the same selection as in F7.

Additional info:
Tested on LiveCD and after installation from LiveCD.
Comment 1 Matthias Clasen 2007-10-06 16:07:19 EDT
I cannot reproduce the problem. 
I see the same lists as always.

What version of xkeyboard-config do you have ?

Moving to F8Blocker for further investigation.
Comment 2 Jeremy Katz 2007-10-07 17:04:54 EDT
*** Bug 322341 has been marked as a duplicate of this bug. ***
Comment 3 Jeremy Katz 2007-10-07 17:06:19 EDT
Matthias -- I see this reliably with live CDs but also don't get it on my
laptop.  So I suspect it's something about fresh installs vs not.  The duped bug
has a screenshot (https://bugzilla.redhat.com/attachment.cgi?id=218881) of the
errors on the tty gnome-keyboard-properties is launched from.
Comment 4 Matthias Clasen 2007-10-08 23:29:16 EDT
There was indeed a problem in with markup in translations in
xkeyboard-config-1.1-1.fc8, but that should be fixed in 1.1-2.fc8.

That is why I want to know what version of xkeyboard-config this problem has
been seen with.
Comment 5 Adam Pribyl 2007-10-09 05:41:28 EDT
This is F8T3 with xkeyboard-config-1.1-1.fc8. After update to current
development xkeyboard-config-1.1-3.fc8 problem seems fixed. If this gets into F8
then please close the bug. Thanx

Note You need to log in before you can comment on or make changes to this bug.