Bug 321611 - Global volume control does not work
Global volume control does not work
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
: 388271 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 17:03 EDT by Julian Sikorski
Modified: 2008-01-18 18:55 EST (History)
2 users (show)

See Also:
Fixed In Version: 0.9.8-4.fc8.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 18:55:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julian Sikorski 2007-10-06 17:03:57 EDT
Description of problem:
I recently installed f8t3 and did some pulseaudio testing. The problem is that I
can control volume per-stream only, not per-device. I guess that's the reason:
W: alsa-util.c: Cannot find mixer control "Master".
Indeed, there is no Master here, the main channel was called PCM when I used
alsa. As a side effect, volume control applet is useless.
pulseaudio-0.9.7-0.15.svn20071001.fc8.x86_64
Comment 1 Lennart Poettering 2007-10-15 13:01:39 EDT
Please make sure to enable the PA output plugin in gnome-sound-properties.
(Which should be the case by default)

The volume that you can adjust with GNOME's mixer applet is the device volume,
if the GStreamer plugin for Pulse is being used.

The warning you mentioned is just that: a warning. PA will fallback to use "PCM"
if "Master" is not available. If neither PCM nor Master are found PA falls back
to software volume control.
Comment 2 Julian Sikorski 2007-10-15 15:19:42 EDT
I'll test it later. Do you actually mean that I need to use gstreamer (no xine,
alsa plugin) to be able to use volume applet, if so, it's quite a regression.
GStreamer is insufficient for certain applications, most notably DVD videos.
Comment 3 Julian Sikorski 2007-10-17 17:26:45 EDT
OK, testing done. I read on fedora-devel-list that gnome-volume-control needs
some work, so let's put that one aside for now. Unfortunately, I am not able to
control global volume with pavucotrol either - sliding the slider in output
devices tab has no effect, however clicking mute has. Per-stream control works
fine. I have a HDA Audio here, Realtek ALC861 if that matters. It would be nice
to have some kind of global volume control, if not in gnome applet, then in
pavucontrol at least.
Comment 4 Lennart Poettering 2007-10-17 17:46:24 EDT
Hmm, so you say that the PA volume control is practically useless? if you open
"alsamixer" and play around with the "Master" slider, does this change anything
with the volume?

If that's the case, then you have a driver bug. 
Comment 5 Julian Sikorski 2007-10-17 17:52:34 EDT
For reference, alsamixer master slider (with pulse plugins set as default) also
does not seem to work.
Comment 6 Julian Sikorski 2007-10-17 19:27:57 EDT
We figured out what is going out on IRC. It turns out this chip (Realtek ALC861)
does not support hardware volume control, and thus needs upstream work for
proper fix.
Comment 7 Lennart Poettering 2007-11-29 20:31:25 EST
*** Bug 388271 has been marked as a duplicate of this bug. ***
Comment 8 Julian Sikorski 2008-01-13 14:56:33 EST
Not sure what happened. I updated to 0.9.8 from rawhide a while ago, but IIRC it
did not solve the issue. I checked today, and voila, global volume control works
perfectly. Maybe an ALSA update delivered support for hardware volume control
for this chip?
Comment 9 drago01 2008-01-14 05:08:32 EST
I have upgraded to pulseaudio-0.9.8-4.fc8.1 and now pulse seems to use front:0
instead of hw:0 and therefor the software volume control provided by alsa is
used by PA. (Soundcard Realtek ALC 861). This also has a positive side effect
that the volume is remembered between reboots. 
Comment 10 Julian Sikorski 2008-01-14 05:33:39 EST
Looks like it is pulseaudio that fixed the issue then. Shall we close this bug now?
Comment 11 Lubomir Kundrak 2008-01-14 06:28:47 EST
Julian: I'll reference this bug in the pulseaudio update and it will be closed
by Bodhi when the update is out.
Comment 12 Fedora Update System 2008-01-15 17:57:20 EST
pulseaudio-0.9.8-4.fc8.1 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pulseaudio'
Comment 13 Fedora Update System 2008-01-18 18:55:28 EST
pulseaudio-0.9.8-4.fc8.1 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.