Bug 32223 - Samba panic while trying to set GID
Samba panic while trying to set GID
Status: CLOSED DUPLICATE of bug 21654
Product: Red Hat Linux
Classification: Retired
Component: samba (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 07:52 EST by Cemagref HHLY SysOp
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 08:43:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cemagref HHLY SysOp 2001-03-19 07:52:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [fr] (X11; U; Linux 2.2.16-22 i686)


Listing shares or connection to a share fail from any machine (Windows
boxes as Linux boxes).

Reproducible: Always
Steps to Reproduce:
1. set up a normal samba configuration (which worked fine with RH6.2)
2. try to connect with smbclient or from a window box

Actual Results:
[root@alpha3 samba]# smbclient -U perreal -L alpha2
SSL: Error error setting CA cert locations: error:00000000::lib(0) :func(0)
:reason(0)
trying default locations.
added interface ip=195.221.113.12 bcast=195.221.113.255 nmask=255.255.255.0
Password:
Domain=[HHLY] OS=[Unix] Server=[Samba 2.0.7]
tree connect failed: code
0                                                                                                                                     

Here is what is found in the log file:

[2001/03/19 13:41:24, 0] lib/util_sec.c:assert_gid(72)
  Failed to set gid privileges to (-1,99) now set to (0,0) uid=(0,0)
[2001/03/19 13:41:24, 0] lib/util.c:smb_panic(2381)
  PANIC: failed to set gid              

The same error reproduce when trying to connect to a share (i.e. smbclient
'\\aplha2\public')

Installed RPM : samba-2.0.7-21ssl
Machine (uname -a): Linux alpha3.xxx 2.2.17-4smp #1 SMP Mon Oct 23 15:03:57
EDT 2000 alpha unknown
Comment 1 Bill Nottingham 2001-03-19 11:13:52 EST

*** This bug has been marked as a duplicate of 21654 ***

Note You need to log in before you can comment on or make changes to this bug.