Bug 322361 - Prompts for GAL password over and over and over again
Prompts for GAL password over and over and over again
Status: CLOSED DUPLICATE of bug 296671
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 13:38 EDT by Jonathan Kamens
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-07 15:01:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-10-07 13:38:00 EDT
For some reason, my OWA server doesn't export the Global Address List at the
/gal URL.  It accepts a post to that URL but rejects the username / password
that is entered.

When I click on "Global Address List" in the addressbook window, it prompts me
for a password.  I enter it.  It prompts me again.  I enter it.  It prompts me
again.  Etc.  Clicking "Cancel" does no good; it prompts me again.  Etc.

In fact, there is no way that I can tell to get out of this vicious circle
expect to force shutdown evolution and then edit
.gconf/evolution/addressbook/display/%gconf.xml to remove the primary address
book setting, so that it won't be selected the next time evolution is started.

This infinite authentication loop needs to be fixed.  Independent of that, it
should be possible to remove the GAL from the UI completely if the Exchange
server being used doesn't export it.

Independent of *that*, if my Outlook client at work can get to the GAL, then
Exchange should be able to as well, but I have no idea how to make that work
(i.e., I have no idea what Evolution is doing differently from Outlook, since
that Outlook is able to access the GAL but Exchange isn't).

I have evolution-exchange-2.12.0-1.fc8 and evolution-2.12.0-3.fc8.
Comment 1 Matthew Barnes 2007-10-07 15:01:11 EDT

*** This bug has been marked as a duplicate of 296671 ***

Note You need to log in before you can comment on or make changes to this bug.