Bug 296671 - Evolution doesn't accept password for "Global Address List"
Evolution doesn't accept password for "Global Address List"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
8
All Linux
high Severity urgent
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 306671 322361 (view as bug list)
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-09-19 13:40 EDT by Valent Turkovic
Modified: 2008-04-02 22:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 00:11:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
E2K_DEBUG=5 log (32.07 KB, text/plain)
2007-10-10 22:05 EDT, Jonathan Kamens
no flags Details
ecvhange GAL settings (47.44 KB, image/png)
2008-01-31 07:41 EST, Valent Turkovic
no flags Details
ecvhange GAL settings (47.44 KB, image/png)
2008-01-31 07:41 EST, Valent Turkovic
no flags Details
bug (204.54 KB, image/png)
2008-01-31 07:48 EST, Valent Turkovic
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 500389 None None None Never

  None (edit)
Description Valent Turkovic 2007-09-19 13:40:38 EDT
Description of problem:
Upon connecting Evolution to Exchange OWA it asks for password and it accepts it
- I can read and delete messages without problem. If I enable in Edit /
Preferences / Autocompletion / Exchange / "Global Address List" then if I try to
reply to an email I get a popup asking again for my exchange password. I enter
it but it is not accepted and I get the popup again! I cannot do anything then
because even if I click "Deny" button I get the pop up again! Only thing I can
do it to kill all evolutio processes and start it again - and only read email
this time.

Version-Release number of selected component (if applicable):
Evolution 2.12 but it was the same with previous versions 2.11.91 and 2.11.92

How reproducible:
Every time I try to reply or compose new email.

Steps to Reproduce:
1. reply to an email or try to enter some name for recipient while composing new
email
2.
3.
  
Actual results:
windows that asks for my password but doesn't accept it!

Expected results:
to be able to reply and write new emails.

Additional info:
Comment 1 Valent Turkovic 2007-09-27 15:06:07 EDT
Can I provide you with some more feedback?

I updated rawhide with latest updates and the bug is still present.
Comment 2 Valent Turkovic 2007-10-02 05:49:22 EDT
I changed it from evolution to evolution-exchange issue. If you need some info
from me just ask.
Comment 3 Matthew Barnes 2007-10-07 15:01:12 EDT
*** Bug 322361 has been marked as a duplicate of this bug. ***
Comment 4 Matthew Barnes 2007-10-10 16:45:11 EDT
I too have seen this from time to time, but I'm having trouble reproducing it at
will.  I know that the "Exchange Operations" plugin has a tendency to disable
itself randomly (or so it seems), and I wonder if that might have something to
do with it.

The next time you see this, can you please try to check whether your "Exchange
Operations" plugin is enabled?  Also, if you discover a sequence of steps or a
set of conditions that cause this problem to occur consistently, that would be
very helpful as well.
Comment 5 Jonathan Kamens 2007-10-10 17:41:04 EDT
I can't check if the plugin is enabled, because as noted in the bug, when this 
starts happening, I just get prompted over and over and over again for the 
password, clicking Cancel doesn't do any good, and the only thing that can be 
done is to kill the UI.  That's a bug that needs to be fixed independent of 
whatever bug is causing the GAL access to fail.  Cancel should mean Cancel, 
darn it.

When I check the plugins right after starting Evolution but before this problem 
manifests, Exchange Operations is enabled.

Reproducing this issue isn't a problem; I can reproduce it at will simply by 
trying to access the GAL.

Would it be useful for me to post a transcript with E2K_DEBUG set to 5?
Comment 6 Matthew Barnes 2007-10-10 19:51:30 EDT
(In reply to comment #5)
> Would it be useful for me to post a transcript with E2K_DEBUG set to 5?

Yes please, as an attachment.

I think what may be happening is a bunch of password prompt messages are getting
queued up very rapidly, and you're having to respond to each one of them. 
Cancel seems to be cancelling the current dialog but not the queued dialogs for
some reason. 

Comment 7 Jonathan Kamens 2007-10-10 22:05:17 EDT
Created attachment 223611 [details]
E2K_DEBUG=5 log

Here's what I did to generate this...

Start evolution.
Switch to addressbook mode.
Select the GAL, which causes the whole repeated-password-prompt dance to start.

evolution --force-shutdown
E2K_DEBUG=5 evolution
Enter the password at the first dialog.
Cancel the second dialog.
evolution --force-shutdown

I replaced my domain name in the log with "domain.name.elided" and the OWA host
name with "owa.host.name.elided".
Comment 8 Valent Turkovic 2007-10-12 07:27:36 EDT
I can confirm this bug is still present on latest Fedora 8 test 3 with all the
latest updates.
Comment 9 Matthew Barnes 2007-10-16 16:14:37 EDT
I disabled a patch in evolution-data-server-2.12.1-2.fc8 that I think may be
contributing to the problem.  Please give it a try to see if it helps with the
constant password prompting.  That will at least tell me if this is a
Fedora-specific problem or an upstream problem.
Comment 10 Milan Crha 2007-10-18 07:44:12 EDT
*** Bug 325661 has been marked as a duplicate of this bug. ***
Comment 11 Milan Crha 2007-10-18 07:50:34 EDT
*** Bug 306671 has been marked as a duplicate of this bug. ***
Comment 12 Jonathan Kamens 2007-10-18 23:34:15 EDT
It's a step in the right direction!  It still doesn't accept my password, but at
least now the Cancel button works.

I assume you meant 1.12.1, not 2.12.1.

  jik
Comment 13 Mikkel Lauritsen 2007-10-19 04:05:14 EDT
With the current F8T3 the problem has disappeared for me - I'm now able to send
mails. It has unearthed bug 240376, but that's a minor issue compared to this.
Thanks!
Comment 14 Matthew Barnes 2007-10-19 08:01:49 EDT
(In reply to comment #12)
> I assume you meant 1.12.1, not 2.12.1.

Yes I did, thanks.

Okay, so it looks like the constant password prompting was caused by a
Fedora-specific patch, and the remaining issue is likely also present in the
upstream code base.
Comment 15 Valent Turkovic 2007-10-20 12:41:17 EDT
I can confirm - I still see this bug on Fedora 8 test 3 with latest updates but
cancel button works so evolution is still usable.
Comment 16 Will Woods 2007-10-22 14:12:42 EDT
Moving to F8Target instead of F8Blocker, since it no longer completely breaks
evolution. 
Comment 17 Valent Turkovic 2007-10-31 04:40:41 EDT
It is nice you made a quick fix. it would be great if the full fix is done
before fedora 8 ships - it that reasonable to expect or not?
Comment 18 Valent Turkovic 2007-11-26 05:07:44 EST
Is there any update for this bug? With latest updates I still see this bug.

I work at an ISP company and we use Exchange for our email servers
(unfortunately)  and I used Fedora Core 6 as my work desktop. I would like to
update my system (ie. clean install) to Fedora 8 but I need 100% working email.
This is a really big issues with anybody who needs an up to date linux desktop
because this bug currently prevents me form migrating to new Fedora 8!

Can you please suggest some way I can use exchange on fedora 8 and so that GAL
works? Some beta version of your evolution packages? Maybe some older versions?

Thank you.
Comment 19 Milan Crha 2007-11-26 05:50:36 EST
Valent, for GAL issue, look at this thread
http://mail.gnome.org/archives/evolution-hackers/2007-November/msg00012.html

Basically, GAL works when you have Authentication type set to Secure password,
it doesn't work with Plaintext password.
Comment 20 Valent Turkovic 2007-11-26 06:49:18 EST
I tried all sugested things from link you provided and it still doesn't work :(

I switched to Secure password, and it didn't work

I closed and reopened Evolution - it still didn't work

I disabled the exchange account, cosed, opened evolution and enabled the account
- and I still get GAL asking for password if I try to reply to any email!

any other ideas?
Comment 21 Valent Turkovic 2007-11-26 06:57:24 EST
Ps. I have exchange account set up also on "old" Fedora Core 6 and there it
works great and WITH Plaintext password - maybe I'm confusing something. I don't
actually know what GAL is used for but I can use my address book that exchange
server keeps for me (I guess that that address book is accesed through GAL).
Replying to emails on this FC6 box works ok, but on my new F8 system when I hit
reply button I get this "Enter password for GAL" maddness!

here is some output from console:

get pero gal://pero;auth=NTLM@owa.server.hr/gal
Find Items 9
Couldn't Get password 9
Remember gal://pero;auth=NTLM@owa.server.hr/gal: 0/4
Get Default 0
Find Items 0
Delete Items owa.server.hr pero 0
get pero gal://pero;auth=NTLM@owa.server.hr/gal
Find Items 9
Couldn't Get password 9
get pero gal://pero;auth=NTLM@owa.server.hr/gal
Find Items 9
Couldn't Get password 9
get pero gal://pero;auth=NTLM@owa.server.hr/gal
Find Items 9
Couldn't Get password 9



exchange url I put in my accout is: https://owa.server.hr/exchange
and username for it is: SERVER\pero


(I changed the username and server so that I don't expose it...)
Comment 22 Jonathan Kamens 2007-11-26 07:10:01 EST
Switching to secure password doesn't work for me either -- I still can't access
the GAL.

I also tried changing my username from DOMAIN\username to username@domain.com,
which the Exchange server accepts, but that also didn't make a difference.
Comment 23 Milan Crha 2007-11-26 07:22:44 EST
When I was testing same issue on our server, then it worked with secure password
and with name without domain, I only used "username". But if it works in FC6,
then it should work in F8 too (for me, it didn't work in Evolution 2.8.x when I
tried without secure password - it probably works only for some issues, not this
one you have).
Comment 24 Valent Turkovic 2007-12-16 07:49:02 EST
I still see this issue even with all updates... is there any other thing I can do?
Comment 25 Norman R. Weathers 2007-12-18 14:00:53 EST
I, too, am having problems now with evolution.  Up until this last update, I had
a working evolution using plaintext password to my exchange server with all
features working (GAL, Calendar, even an extra group (shared) calendar).  After
this last series of updates, my evolution is hopelessly messed up.  First, it
can't see all of the email in my email account (I can get on the OWA and see all
of it, but evolution has decided to only see "new" things since its update),
calendaring gives me the hopeless errors about not being able to log in
(although, it looks like it is trying to open our public folders server and not
the exchange server...), GAL will gladly take a password, not even prompt about
not being able to use it, and immediately give you back another password dialog
box, and my Tasks entry is also broken (there again, instead of trying to get to
the exchange server, it looks like it is trying to attach to our Public Folders
server...).

If there is anything I can get (dump, debug), please let me know.  I am itching
to get this working.  I had to dust off my old Windows box and try to figure out
how to use outlook again (grin).

Norman Weathers
Comment 26 Valent Turkovic 2008-01-12 16:07:12 EST
I have latest updates and I still see an box asking for my GAL password when I
hit reply to any email! This is really annoying because on each reply I do I
first have to say cancel to password request and then I can write my reply :( 
Comment 27 Jonathan Underwood 2008-01-13 10:28:53 EST
I hate to add a "me too" without adding any new info.. but, well, me too. Up to
date F8 system manifests this bug as described.
Comment 28 Otto Rey 2008-01-13 12:55:48 EST
Some additional data:

- In my work just one of four Fedora 8 installations show this problem.
- In the problematic one, i workaround this problem doing this: change the GAL
server to another (my company have more that one), close evolution, open, and
change to original one. Close and open again. Put the password when evolution
ask me and no more problems with it. I really don't know what happen.

Did you try to remove and create the account again?
Comment 29 Kjartan Maraas 2008-01-30 09:01:08 EST
Could this be related to the keyring issues that were fixed in rawhide earlier?
Maybe F8 needs an updated gnome-keyring package with the race fix?

2008-01-14  Stef Walter  <stef@memberwebs.com>

        * common/gkr-async.c: Fix race condition that is causing
        a deadlock in bug #502603.
Comment 30 Matthew Barnes 2008-01-30 11:04:02 EST
Bug #351411 might be related.  It mentions gnome-screensaver as a possible culprit.
Comment 31 Matthew Barnes 2008-01-30 12:50:08 EST
I tested Evolution 2.12.3 under RHEL 5 and was able to connect to an Exchange
server's Global Address List, so this suggests the source of the problem may
indeed be gnome-keyring or something else external to Evolution.

Does anyone still observe this bug using evolution-2.12.3-1.fc8 and
gnome-keyring-2.20.2-1.fc8 ?
Comment 32 Jonathan Kamens 2008-01-30 13:44:00 EST
I have evolution-2.21.5-2.fc9, evolution-data-server-2.21.5-3.fc9, evolution-
exchange-2.21.5-1.fc9, and gnome-keyring-2.21.5-3.fc9.  I can't update to 
anything later than those without encountering unresolved dependencies.  I 
can't test whether this issue persists with those versions because whenever I 
try to access my Exchange mailbox, contacts or GAL, the Exchange backend 
process crashes.  I tried removing and re-adding the Exchange account and that 
didn't solve the problem.
Comment 33 Valent Turkovic 2008-01-31 07:40:58 EST
I have;
gnome-keyring - 2.20.2-1.fc8.i386 installed and
evolution - 2.12.3-1.fc8.i386 installed

I still see this bug when I hit reply.
On my old evolution under FC6 I don't see this error.
I don't have any GAL server defined and that works ok in FC6 but I get error in
F8  with versions of Evolution and gnome-keyring I have specified.

I'll attach a screenshot.
Comment 34 Valent Turkovic 2008-01-31 07:41:29 EST
Created attachment 293575 [details]
ecvhange GAL settings
Comment 35 Valent Turkovic 2008-01-31 07:41:34 EST
Created attachment 293576 [details]
ecvhange GAL settings
Comment 36 Valent Turkovic 2008-01-31 07:48:24 EST
Created attachment 293577 [details]
bug

When ever I hir reply I get this and I need to click on "cancel"
Comment 39 Matthew Barnes 2008-03-12 00:11:58 EDT
I believe this is fixed now in evolution-data-server-2.22.0-2.fc9 using the
patch from http://bugzilla.gnome.org/show_bug.cgi?id=500389.

Evolution is configured with NTLM support, and it turns out when authenticating
to a Global Catalog server, Evolution insists on using NTLM authentication.  But
some GC servers are not configured for NTLM authentication.

The patch forces Evolution to try a simpler authentication method if NTLM fails.
 It's not an ideal solution -- Evolution should have a separate authentication
method option for Global Catalog servers -- but this should do for now.

Please reopen if the problem persists with evolution-data-server-2.20.0-2.fc9 or
later.
Comment 40 Valent Turkovic 2008-03-17 14:52:35 EDT
this seams to work in Rawhide at the moment!
Last update completely broke my evolution so that it won't even connect to
exchange server so I can't test it under F8
Comment 41 Matthew Barnes 2008-03-17 15:28:41 EDT
(In reply to comment #40)
> Last update completely broke my evolution so that it won't even connect to
> exchange server so I can't test it under F8

What update was that?
Comment 42 Valent Turkovic 2008-03-18 05:20:07 EDT
Maybe it wasn't an update, I'm not sure 100% it was, just now my evolution loses
connection to exchange process - I fined a new bug for it.
Comment 43 Jonathan Kamens 2008-04-02 13:33:23 EDT
I have all current packages from Rawhide.

I stopped evolution with evolution --force-shutdown, deleted ~/.evolution 
recursively, deleted ~/.gconf/apps/evolution recursively (after stopping the 
gconf daemon), and restarted evolution.  I configured my Exchange account, and 
then tried to access the Global Address List. It prompted me for a password 
only once.  Then gnome-keyring-daemon, evolution, and evolution-exchange-
storage started sucking all available CPU between them, with gnome-keyring-
daemon the big winner at around 75% of available CPU, and my load average shot 
up to >3.  This continued for as long as I let it, and needless to say, my 
Global Address List was not displayed.

Switching away from viewing my global address list did not make the CPU suckage 
stop; only exiting from evolution did that.

I tried stopping evolution, blowing away all of my keyrings, and starting 
evolution again.  That didn't help.

In short, at least for me, this does not appear to be fixed.
Comment 44 Matthew Barnes 2008-04-02 13:51:26 EDT
Sounds like a different issue.  Check bug #354041.
Comment 45 Jonathan Kamens 2008-04-02 22:07:35 EDT
The workaround listed in that ticket, blowing away ~/.gnome2/keyrings, does not
solve the problem.

It may in fact be a different issue, but I can't verify that *this* ticket is
fixed until whatever *that* issue is, is fixed as well.

Note You need to log in before you can comment on or make changes to this bug.