Bug 32341 - TypeError: comp file version 3 or 4 expected immediately after rpm grouping on installation anaconda.real
TypeError: comp file version 3 or 4 expected immediately after rpm grouping ...
Status: CLOSED DUPLICATE of bug 32340
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 19:57 EST by Bob Lo
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 19:57:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Lo 2001-03-19 19:57:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (WinNT; U)


after rpm grouping (prepare to select packaging), tracebac occurs and
machine reload.  This same problem occurs in 6.2 too.  So I tried 
7.0, same problem still occurs

Reproducible: Always
Steps to Reproduce:
1. 1 scsci hd 1.0G adaptec 2940 and one ide dr 2.6 G
2. award modular bios eisa and pci system board
3. one eisa token ring and one fe 3com 595.  After removing 3com fe, same problem
    still occurs.
4 just follow installation instruction, after setting locale, then packaging grouping starts
after that, the problme occurs
	

Actual Results:  The following traceback occurs

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getComp
sList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in rea
dComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init
__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in readCo
mpsFile
TypeError: comp file version 3 or 4 expected

Local variables in innermost frame:
arch2: i586

Expected Results:  Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getComp
sList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in rea
dComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init
__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in readCo
mpsFile
TypeError: comp file version 3 or 4 expected

Local variables in innermost frame:
arch2: i586
Comment 1 Bill Nottingham 2001-03-19 21:38:44 EST

*** This bug has been marked as a duplicate of 32340 ***

Note You need to log in before you can comment on or make changes to this bug.