Bug 32340 - TypeError: comp file version 3 or 4 expected immediately after rpm grouping on installation anaconda.real
TypeError: comp file version 3 or 4 expected immediately after rpm grouping ...
Status: CLOSED DUPLICATE of bug 18469
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 32341 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 19:56 EST by Bob Lo
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-30 16:15:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Lo 2001-03-19 19:56:22 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.5 [en] (WinNT; U)


after rpm grouping (prepare to select packaging), tracebac occurs and
machine reload.  This same problem occurs in 6.2 too.  So I tried 
7.0, same problem still occurs

Reproducible: Always
Steps to Reproduce:
1. 1 scsci hd 1.0G adaptec 2940 and one ide dr 2.6 G
2. award modular bios eisa and pci system board
3. one eisa token ring and one fe 3com 595.  After removing 3com fe, same problem
    still occurs.
4 just follow installation instruction, after setting locale, then packaging grouping starts
after that, the problme occurs
	

Actual Results:  The following traceback occurs

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getComp
sList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in rea
dComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init
__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in readCo
mpsFile
TypeError: comp file version 3 or 4 expected

Local variables in innermost frame:
arch2: i586

Expected Results:  Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line
33, in __call__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 539, in getComp
sList
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in rea
dComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init
__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 360, in readCo
mpsFile
TypeError: comp file version 3 or 4 expected

Local variables in innermost frame:
arch2: i586
Comment 1 Bill Nottingham 2001-03-19 21:38:36 EST
*** Bug 32341 has been marked as a duplicate of this bug. ***
Comment 2 Bob Lo 2001-03-20 00:10:25 EST
I am using custom install option.  Also I've tried remove all the adaptor cards except the bare
minimun, ie video card and ide card and the problem still occurs.  I've tried with debian
2.0 and had no problem.
Comment 3 Michael Fulbright 2001-03-21 14:10:27 EST
What are you installing from (CD, network, etc)?
Comment 4 Bob Lo 2001-03-22 18:46:14 EST
I am installing from hard drive.  Originally I have 2 hd, one ide 2.5 G and
the other scsi 1.0 G.  The redhat binary is store 2nd partition of 2.5 G hd.
Its first partition was installed with NT 4.0 terminal server.  I am trying
to install liniux on 1.0 G scsi but failed.  But later I tried removing the
scsi adapter and hd and just partition ide to 3.  And then I tried to 
install linux on the 3rd partion of ide hd still failed.
Comment 5 Brent Fox 2001-03-30 16:15:23 EST
Can you check the md5sums of the isos that you downloaded?  Sounds like
something may have gone wrong in the transfer.
Comment 6 Brent Fox 2001-03-30 16:15:48 EST

*** This bug has been marked as a duplicate of 18469 ***
Comment 7 Bob Lo 2001-04-01 17:40:04 EDT
How do I check the md5sums of the isos ?

Thanks


Note You need to log in before you can comment on or make changes to this bug.