Bug 323831 - Renaming translation po file from sr@Latn to sr@latin
Renaming translation po file from sr@Latn to sr@latin
Status: CLOSED RAWHIDE
Product: Fedora Localization
Classification: Fedora
Component: Serbian [sr] (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Igor Miletic
Miloš Komarčević
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 16:59 EDT by Miloš Komarčević
Modified: 2008-01-21 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-21 17:52:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Komarčević 2007-10-08 16:59:29 EDT
+++ This bug was initially created as a clone of Bug #312421 +++

Please rename all remaining sr@Latn po files on i18n.redhat.com CVS to sr@latin
as the locale label has changed in glibc recently. Any Makefiles, LINGUAS
variables etc. should be updated to reflect the change as well, as well as the
ACLs for commit privileges.

The "essential modules" had individual requests filed already: bug #312421, bug
#312431, bug #312441, bug #312451 and bug #312461.
Comment 1 Chester Cheng 2007-10-08 20:06:51 EDT
I'll look into it.
Comment 2 Chester Cheng 2007-10-08 23:25:35 EDT
Hi,

On elvis.redhat.com, the sr@latin is created.  All users that belong to sr@Latn
are members of sr@latin.  Feel free to copy sr@Latn.po to sr@latin.po and commit.

Please kindly advice if you face any problem.

Thank you.

Regards,
Chester
Comment 3 Miloš Komarčević 2007-10-09 05:38:00 EDT
Hi Chester,

Thanks. I did run into problems with some of the older modules. It looks like
there was briefly "sr@Latin" in CVS long time ago (guess created by mistake
instead of "sr@Latn" when we first asked for it) so now  the server complains, e.g.:

Testing sr@latin.po...
**** Access allowed: kmilos is in ACL for authconfig/po.
RCS file: /usr/local/CVS/kudzu/po/sr@latin.po,v
done
cvs: commit.c:2049: checkaddfile: Assertion `*rcsnode == ((void *)0)' failed.
cvs [server aborted]: received abort signal

Error, CVS operation failed

Tortoise Tip: This error can be caused because there used to be a file in the
repository with a name differing only by case from the one you are adding. For
example TEST.EXE rather than test.exe. To fix this go into the repository, or
get your administrator to, and rename that file to have the same case. It will
be in the Attic folder underneath the folder you are in. You will also need to
get the local sandbox folder you are in out of CVS again, as it may have bogus
entries to the misspelt filename.

I did manage to commit a couple of the newer modules, I guess that were added to
the repository later.
Comment 4 Chester Cheng 2007-10-09 20:52:14 EDT
Hi Milos,

I see kudzu/sr@latin on my Linux computer.  Is the file in your computer says
sr@Latin?  It seems that this is because Windows does not distinguish upper case
and lower case.  Maybe you can change the filename into lower case and see how
it goes.

Cheers,
Chester
Comment 5 Miloš Komarčević 2007-10-10 03:59:00 EDT
I got kudzu/sr@latin.po through CVS now as well, I presume you committed it?

No, I don't have any sr@Latin.po in my sandbox, all are lower case, and although
I managed to cvs add, I can't commit most of them. I might try checking out a
fresh sandbox on my Fedora partition and try committing from there.
Comment 6 Chester Cheng 2007-10-10 20:30:32 EDT
kudzu/sr@latin.po has been there since 2006.  I didn't do it.  ;)

I've seen these after "cvs up":
$ ls */sr\@latin.po
anaconda/sr@latin.po         pykickstart/sr@latin.po
firstboot/sr@latin.po        rhgb/sr@latin.po
kexec-tools/sr@latin.po      rhn-client-tools/sr@latin.po
kudzu/sr@latin.po            rhnsd/sr@latin.po
libvirt/sr@latin.po          setroubleshoot/sr@latin.po
password/sr@latin.po         system-config-kdump/sr@latin.po
policycoreutils/sr@latin.po  yum-rhn-plugin/sr@latin.po

However, I also see some strange messages such as:
cvs server: Updating system-config-rootpassword
cvs server: nothing known about system-config-rootpassword/sr@latin.po

Let's see what's the result of your test.

Cheers,
Chester
Comment 7 Miloš Komarčević 2007-10-11 18:44:05 EDT
Chester,

I get pretty much the same on my clean checkout on my fedora box, here's a
transcript of my session:

$ cvs -z9 co translate/
Enter passphrase for key '/home/milos/.ssh/id_dsa':
...
cvs server: Updating rhn-applet
...
cvs server: nothing known about rhn-applet/sr@latin.po
...

$ cd rhn-applet/

$ cp sr\@Latn.po sr\@latin.po

$ cvs commit -m 'initial checkin of sr@latin translation' sr\@latin.po 
cvs commit: use `cvs add' to create an entry for sr@latin.po
cvs [commit aborted]: correct above errors first!

$ cvs add sr\@latin.po 
Enter passphrase for key '/home/milos/.ssh/id_dsa': 
cvs server: scheduling file `sr@latin.po' for addition
cvs server: use 'cvs commit' to add this file permanently

$ cvs commit -m 'initial checkin of sr@latin translation' sr\@latin.po 
Enter passphrase for key '/home/milos/.ssh/id_dsa': 
cvs: hash.c:312: findnode: Assertion `key != ((void *)0)' failed.
cvs [server aborted]: received abort signal


So, the message is the same as with TortoiseCVS on Windows.

However, I did manage to commit a handful more modules for which I don't get
"cvs: nothing known...", and the remaining with problems are:

cvs server: nothing known about authconfig/sr@latin.po
cvs server: nothing known about autorun/sr@latin.po
cvs server: nothing known about chkconfig/sr@latin.po
cvs server: nothing known about initscripts/sr@latin.po
cvs server: nothing known about libuser/sr@latin.po
cvs server: nothing known about rhn-applet/sr@latin.po
cvs server: nothing known about system-config-keyboard/sr@latin.po
cvs server: nothing known about system-config-kickstart/sr@latin.po
cvs server: nothing known about system-config-language/sr@latin.po
cvs server: nothing known about system-config-lvm/sr@latin.po
cvs server: nothing known about system-config-netboot/sr@latin.po
cvs server: nothing known about system-config-network/sr@latin.po
cvs server: nothing known about system-config-rootpassword/sr@latin.po
cvs server: nothing known about system-config-securitylevel/sr@latin.po
cvs server: nothing known about system-config-soundcard/sr@latin.po
cvs server: nothing known about system-switch-mail/sr@latin.po
cvs server: nothing known about usermode/sr@latin.po
Comment 8 Chester Cheng 2007-10-12 01:18:05 EDT
Hi Milos,

Seems I can't fix this issue.  I've forward this to our system admin team and
will keep you updated.

Regards,
Chester
Comment 9 Miloš Komarčević 2008-01-21 17:52:20 EST
Bill Nottingham has managed to do sort it out after I pinged the
fedora-trans-list, the transition is now done on elvis.

I'll file individual bug reports for modules that do not pick up the change and
need intervention in order to ship the new translations.

Thanks

Note You need to log in before you can comment on or make changes to this bug.