Bug 32397 - RFE: Handle existing but incomplete RAID superblocks more gracefully
Summary: RFE: Handle existing but incomplete RAID superblocks more gracefully
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
: 71679 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 15:27 UTC by Karsten Hopp
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-28 22:37:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback (417.85 KB, text/plain)
2001-03-20 15:28 UTC, Karsten Hopp
no flags Details

Description Karsten Hopp 2001-03-20 15:27:41 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [de] (X11; U; Linux 2.4.2-0.1.29 i686)


anaconda fails with a traceback as soon as I click (GUI) on 
'upgrade existing installation'

Reproducible: Always
Steps to Reproduce:
1. use one partition of an old, unuses software raid for your test
installation
2. GUI mode
3. klick on 'upgrade existing installation'
	

Actual Results:  I'll attach the traceback

Expected Results:  Warning, that software raid is corrupt or something like
this, but not a complete
failure.

Comment 1 Karsten Hopp 2001-03-20 15:28:49 UTC
Created attachment 13143 [details]
anaconda traceback

Comment 2 Glen Foster 2001-03-20 16:15:23 UTC
Changing product to Red Hat Linux Beta (internally) since the rest of the world
doens't need to know about our internal tree builds.

Comment 3 Michael Fulbright 2001-03-20 16:23:24 UTC
Could you send your /etc/raidtab and fdisk -l output for /dev/hda and /dev/hdc?


Comment 4 Karsten Hopp 2001-03-20 17:04:30 UTC
There  is no /etc/raidtab. I once had one for testing, but I don't use software
raid anymore.
There is only one partition of the former raid remaining:

[karsten@kaarst karsten]$ sudo /sbin/fdisk -l /dev/hda
 
Festplatte /dev/hda: 255 Kvpfe, 63 Sektoren, 790 Zylinder
Einheiten: Zylinder mit 16065 * 512 Bytes
 
    Gerdt Booten  Anfang      Ende   Blvcke   ID  Dateisystemtyp
/dev/hda1   *         1        17    136521   82  Linux (Auslagerung)
/dev/hda2            18       790   6209122+   5  Erweiterte
/dev/hda5            18       170   1228941   83  Linux
/dev/hda6           171       425   2048256   83  Linux
/dev/hda7           426       578   1228941   83  Linux
/dev/hda8           579       790   1702858+  83  Linux
[karsten@kaarst karsten]$ sudo /sbin/fdisk -l /dev/hdc
 
Festplatte /dev/hdc: 16 Kvpfe, 63 Sektoren, 29795 Zylinder
Einheiten: Zylinder mit 1008 * 512 Bytes
 
    Gerdt Booten  Anfang      Ende   Blvcke   ID  Dateisystemtyp
/dev/hdc1             1       261    131512+  82  Linux (Auslagerung)
/dev/hdc2           262     29795  14885136    5  Erweiterte
/dev/hdc5           262     20579  10240240+  83  Linux
/dev/hdc6         20580     24643   2048224+  83  Linux
/dev/hdc7         24644     29795   2596576+  fd  Linux-RAID, autom. Erkennung

The bugreport wasn't about anaconda not being able to configure my raid, but 
bailing out with
a traceback if there is an unusual setup like mine.

Comment 5 Michael Fulbright 2001-03-20 19:45:07 UTC
I understand now - I will note for next release to handle this situation more
gracefully. It is too late to change the behavior this release.

Thanks for catching this case, btw.

Comment 6 Michael Fulbright 2002-08-23 16:09:19 UTC
*** Bug 71679 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2003-07-28 22:37:19 UTC
This is handled better now


Note You need to log in before you can comment on or make changes to this bug.