Bug 71679 - anaconda crashes on raid.py line 43 while scanning for raid devices
Summary: anaconda crashes on raid.py line 43 while scanning for raid devices
Status: CLOSED DUPLICATE of bug 32397
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-16 16:42 UTC by Eugenio Diaz
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 04:46:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback dump of anaconda state generated by itself after crash (65.77 KB, text/plain)
2002-08-16 16:46 UTC, Eugenio Diaz
no flags Details

Description Eugenio Diaz 2002-08-16 16:42:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
System info:
 gBox P4 (CF-S868) Flex-ATX (http://www.amselectronics.com)
 512MB RAM
 2x 80GB Western Digital Drives (WDC800JB)

Problem:
 Anaconda crashed whenever you have at least one raid (auto) partition on any of
the drives. The crash occurs at line 43 of the /usr/lib/anaconda/raid.py file
right after it finished formating all the partitions.

My first try was a simple install using 2x250MB on a raid1 for /boot, 2x10GB
unused partitions (intended for windows dual boot, but initially set to unsused
raid), and 2x60GB+ on a raid0 for /. This failed, so I tried with an ext3 /boot
on just one of the 250MB partitions and the rest the same; failed. Next I tried
eliminating the raids from the install by putting /boot on one of the 250MB
partitions, and / on one of the 10GB partitions, both on hda, failed again. Next
we tried the same scenario, but deleting all the partitions of type raid; it worked.

So, my take on it is that it fails while scanning for autodetect raid partitions.

Logs:

anaconda.txt is attached



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

	

Additional info:

Comment 1 Eugenio Diaz 2002-08-16 16:46:43 UTC
Created attachment 71184 [details]
traceback dump of anaconda state generated by itself after crash

Comment 2 Michael Fulbright 2002-08-19 15:59:48 UTC
If you have any partitions set as type raid they need to be part of a valid raid
array.

Comment 3 Eugenio Diaz 2002-08-21 04:46:42 UTC
And you think this is ok behaviour?

I mean, what if I have 5 or 10 disks, and I want to pre-partition as raid
autodetect partitions to be used later? In my case I had a 10GB partition on
each drive that I was going to use later on as a mirror or stripe, but first I
was going to use one of them to install windows and do some testing, so I
defined them as type "fd".

Unless we are know in competition with Microsoft for bad programming, this
certainly bad behaviour. At the least, if you do not want the user to define
raid partitions that are not used, then give out a message, but crashing the
whole install program! duh!

Comment 4 Michael Fulbright 2002-08-23 16:09:25 UTC
Yes it is certainly something we would like to address.  We are getting to these
types of issues as time allows.

*** This bug has been marked as a duplicate of 32397 ***


Note You need to log in before you can comment on or make changes to this bug.