Bug 324701 - virt-install lacks XML escaping of extra-args
virt-install lacks XML escaping of extra-args
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: python-virtinst (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Cole Robinson
Virtualization Bugs
:
Depends On:
Blocks: 428209
  Show dependency treegraph
 
Reported: 2007-10-09 07:13 EDT by Joe Orton
Modified: 2009-12-14 16:17 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2008-0371
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 12:45:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Joe Orton 2007-10-09 07:15:43 EDT
Changing the & in the -x argument to & gets further, then fails with:

libvirt.libvirtError: virDomainCreateLinux() failed POST operation failed:
(xend.err 'Invalid configuration unexpected EOF')
Comment 2 Cole Robinson 2008-01-09 17:42:21 EST
I just added the fix for this upstream:

http://hg.et.redhat.com/virt/applications/virtinst--devel?cs=207e1674c298

Though there seems to be errors at the libvirt/xend level that are preventing
this from working as well.
Comment 3 RHEL Product and Program Management 2008-01-09 17:45:53 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Cole Robinson 2008-01-17 13:13:12 EST
We are rebasing to virtinst-0.300.2, which fixes this bug:

$ brew latest-pkg dist-5E-qu-candidate python-virtinst
Build                                     Tag                   Built by
----------------------------------------  --------------------  ----------------
python-virtinst-0.300.2-1.el5             dist-5E-qu-candidate  berrange

virt-install now does the correct thing, though there are still other errors
that are holding up this from fully working (bz 428879), so this still won't
fully work. The difference is you will see the error in comment #2 as opposed to
the error in comment #1 :)
Comment 8 errata-xmlrpc 2008-05-21 12:45:10 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0371.html

Note You need to log in before you can comment on or make changes to this bug.