Bug 324901 - dhcpv6-client doesn't obsolete dhcpv6_client-0.10-44.fc7
Summary: dhcpv6-client doesn't obsolete dhcpv6_client-0.10-44.fc7
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcpv6 (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix, Patch
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-10-09 14:14 UTC by Lubomir Kundrak
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 14:30:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lubomir Kundrak 2007-10-09 14:14:53 UTC
Description of problem:

The latest Fedora 7 version of dhcpv6_client is dhcpv6_client-0.10-44.fc7. In
the newer version the underscore was replaced with a dash and the Obsolete tag
was added. Unfortunatelly, not correctly.

Version-Release number of selected component (if applicable):

dhcpv6-client-0.10-50.fc8

How reproducible:



Steps to Reproduce:
1. Run Fedora 7
2. $ yum --enablerepo=development install dhcpv6-client
  
Actual results:

Transaction Check Error:
  file /sbin/dhcp6c from install of dhcpv6-client-0.10-50.fc8 conflicts with
file from package dhcpv6_client-0.10-44.fc7

Additional info:

The Obsolete clause currently reads:

Obsoletes: dhcpv6_client <= 0.10-44

which doesn't match the Fedora 7 version, probably due to the .fc7 dist tag:

[root@richman ~]# yum provides 'dhcpv6_client <= 0.10-44'
Loading "installonlyn" plugin
fedora                    100% |=========================| 2.1 kB    00:00     
primary.sqlite.bz2        100% |=========================| 3.8 MB    00:07     



dhcpv6_client.i386                       0.10-42.fc7            fedora          
Matched from:
dhcpv6_client <= 0.10-44



dhcpv6_client.i386                       0.10-42.fc7            installed       
Matched from:
Provides-match: dhcpv6_client <= 0.10-44
[root@richman ~]# 

Anyways, pining an Obsolete to a specific version is not a good idea, as it
prevents updates of the package in older distribution. An unversioned Obsolete
tag would do:

Obsoletes: dhcpv6_client

Comment 1 Lubomir Kundrak 2007-10-09 14:17:01 UTC
This prevents upgrade from FC7 to FC8 with yum.

Comment 2 David Cantrell 2007-10-09 14:30:13 UTC
Thanks for the report, fixing this in rawhide.  I did rename the package to
remove the underscore because I hate underscores in package names.  I've changed
it so dhcpv6-client obsoletes dhcpv6_client without the nvr info.


Note You need to log in before you can comment on or make changes to this bug.