Bug 324971 - Overlapping mpaths
Overlapping mpaths
Status: CLOSED DUPLICATE of bug 320151
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.5
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 10:49 EDT by Mimmus
Modified: 2010-01-11 21:31 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-26 18:35:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of "multipath -v3" (9.39 KB, text/plain)
2007-10-09 10:49 EDT, Mimmus
no flags Details
Output of "vgdisplay -v" (5.00 KB, text/plain)
2007-10-09 10:51 EDT, Mimmus
no flags Details
multipath.conf (242 bytes, text/plain)
2007-10-09 10:54 EDT, Mimmus
no flags Details

  None (edit)
Description Mimmus 2007-10-09 10:49:32 EDT
Description of problem:
Just after a reboot, this is the output of "multipath -ll":
mpath9 (360060160eb24170010eb64e5104adb11)
[size=70 GB][features="1 queue_if_no_path"][hwhandler="1 emc"]
\_ round-robin 0 [prio=2][active]
 \_ 0:0:3:58 sde 8:64  [active][ready]
 \_ 1:0:1:58 sdk 8:160 [active][ready]
\_ round-robin 0 [enabled]
 \_ 0:0:2:58 sdb 8:16  [active][ready]
 \_ 1:0:0:58 sdh 8:112 [active][ready]

mpath13 (360060160eb241700cebbbda6cc4edb11)
[size=50 GB][features="1 queue_if_no_path"][hwhandler="1 emc"]
\_ round-robin 0 [prio=2][active]
 \_ 0:0:3:62 sdf 8:80  [active][ready]
 \_ 1:0:1:62 sdl 8:176 [active][ready]
\_ round-robin 0 [enabled]
 \_ 0:0:2:62 sdc 8:32  [active][ready]
 \_ 1:0:0:62 sdi 8:128 [active][ready]

If I run "multipath -v2", I get:
 remove: mpath9 (dup of mpath1)
 mpath9: map in use
 remove: mpath13 (dup of mpath2)
 mpath13: map in use
(attached larger output of "multipath -v3")

Version-Release number of selected component (if applicable):
 latest with 4.5

How reproducible:
 always

Steps to Reproduce:
1. Reboot
2. multipath -ll
3. multipath -v3
  
Actual results:
 "dup mpaths"

Expected results:
 no "dup mpaths"

Additional info:
 storage is a EMC Clariion CX700
Comment 1 Mimmus 2007-10-09 10:49:32 EDT
Created attachment 221351 [details]
Output of "multipath -v3"
Comment 2 Mimmus 2007-10-09 10:51:52 EDT
Created attachment 221361 [details]
Output of "vgdisplay -v"

Problem is with volume groups "vg_58" and "vg_62"
Comment 3 Mimmus 2007-10-09 10:54:27 EDT
Created attachment 221371 [details]
multipath.conf

Default config file except for blacklist, where I put EMC controller wwid
Comment 4 Mimmus 2007-10-12 08:47:28 EDT
Still no chance to get this working.
Only using "user_friendly_names no" seems to solve the problem.
Comment 5 Ben Marzinski 2007-10-12 14:16:11 EDT
Can you please post your /var/lib/multipath/bindings file.  This is the file that
maps the WWIDs onto user_friendly_names.
Comment 6 Ben Marzinski 2007-10-26 18:35:46 EDT
Without any more information, I'm going to assume that this the same problem as
bz #320151.  If This is incorrect, please reopen the bug.

*** This bug has been marked as a duplicate of 320151 ***

Note You need to log in before you can comment on or make changes to this bug.