Bug 320151 - bindings file location is problematic for certain configurations
bindings file location is problematic for certain configurations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
All Linux
urgent Severity high
: ---
: ---
Assigned To: Ben Marzinski
Corey Marthaler
:
: 324971 (view as bug list)
Depends On:
Blocks: 357331
  Show dependency treegraph
 
Reported: 2007-10-05 09:57 EDT by Josef Bacik
Modified: 2010-10-22 15:17 EDT (History)
15 users (show)

See Also:
Fixed In Version: RHEA-2007-0808
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:16:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch that resolves the problem (755 bytes, patch)
2007-10-05 09:57 EDT, Josef Bacik
no flags Details | Diff

  None (edit)
Description Josef Bacik 2007-10-05 09:57:58 EDT
Some customers are using the /var/lib/multipath/bindings file to make sure 
they have consistent device naming across a cluster.  Their cluster nodes 
however are setup with /var on a separate partition.  The way our init scripts 
work, /var isn't mounted until after the multipathing setup has occurred, so 
the bindings file is never read.  You can only specify a different bindings 
file location via the command line, which in this case would require that the 
customer hand edit the rc.sysinit script in order to change the location of 
the bindings file.  This is not an acceptable solution.  This patch allows 
these customers to specify their own bindings file location in the defaults{} 
section of the multipath.conf.
Comment 1 Josef Bacik 2007-10-05 09:57:58 EDT
Created attachment 217361 [details]
patch that resolves the problem
Comment 5 Joshua Jensen 2007-10-10 14:42:06 EDT
All customers using multipath use /var/lib/multipath/bindings :-)

multipath uses this file, as you know, for multipath cache... which doesn't take
on reboot on many many servers because /var isn't yet mounted.

Thats the problem.  rc.sysinit could call multipath with the "-b" option to
specify a different location for the bindings file, but doen't.
Comment 7 Josef Bacik 2007-10-11 13:56:04 EDT
changing summary as this isnt really an RFE
Comment 8 Ben Marzinski 2007-10-11 17:45:22 EDT
Patch applied.  I will move the bindings file to /etc for RHEL6.
Comment 15 Ben Marzinski 2007-10-26 18:35:48 EDT
*** Bug 324971 has been marked as a duplicate of this bug. ***
Comment 17 errata-xmlrpc 2007-11-15 11:16:33 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0808.html

Note You need to log in before you can comment on or make changes to this bug.