Bug 325661 - Exchange folder contents don't synchronize
Exchange folder contents don't synchronize
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution-exchange (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 18:06 EDT by Jonathan Kamens
Modified: 2009-01-09 02:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-09 02:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2007-10-09 18:06:25 EDT
I am staring at an Evolution window which is showing a message in my Exchange
INBOX which isn't actually *in* my Exchange inbox.

Outlook on my laptop doesn't show the message.  Outlook on my PC at work doesn't
show the message.  OWA doesn't show the message.  My Windows Mobile device
doesn't show the message.  Thunderbird talking IMAP to the server doesn't show
the message.  And yet Evolution still thinks it's there.

I've tried emptying the trash.  I've tried refreshing the folder.  I've tried
expunging the folder.  I've tried exiting and restaring Evolution.  I've tried
doing evolution --force-shutdown.  I've tried going offline and back online. 
I've tried disabling and enabling the Exchange account.  Nothing has made the
message go away.

It's worth noting that the message was moved from my INBOX into another folder
using Outlook at work, while Evolution was running at home.

I have seen this happen lots of times recently.  When it does happen, the errant
message does eventually go away at some indefinite time in the future.

Note that Evolution correctly notices other changes to the folder, e.g., newly
received messages, while this problem is manifesting.

I have evolution-2.12.0-6.fc8 and evolution-exchange-2.12.0-1.fc8.
Comment 1 Milan Crha 2007-10-18 07:44:11 EDT

*** This bug has been marked as a duplicate of 296671 ***
Comment 2 Milan Crha 2007-10-18 07:47:10 EDT
I'm sorry, I marked wrong bug as duplicate.
Comment 3 Milan Crha 2007-10-18 09:05:23 EDT
I had a chat with upstream developer of evolution-exchange, and there are some
things he would like to know before making any decision(s):
a) Are you able to see the message in the folder where you moved to, in Evolution?
b) How reliably can you reproduce this bug, with other message/folder?
c) Can you try same test with evolution-exchange 2.10.x? (probably on a virtual
machine or something)
This will help to narrow down the scope of problem. Thanks in advance.
Comment 4 Jonathan Kamens 2007-10-18 13:49:27 EDT
a) Yes.
b) I can't reproduce the problem reliably.
c) No, not an option.  No resources or time to set this up.
Comment 5 Bug Zapper 2008-11-26 02:56:35 EST
This message is a reminder that Fedora 8 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 8.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '8'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 8's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 8 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Bug Zapper 2009-01-09 02:18:48 EST
Fedora 8 changed to end-of-life (EOL) status on 2009-01-07. Fedora 8 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.