Bug 325671 - Add user screen offers to force a weak password but fails anyway
Add user screen offers to force a weak password but fails anyway
Status: CLOSED DUPLICATE of bug 296651
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 18:12 EDT by Diego Escalante Urrelo
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 09:45:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Diego Escalante Urrelo 2007-10-09 18:12:19 EDT
Description of problem:
Well, the summary is not really descriptive, here it goes:
Boot Fedora for the first time after installing, you will be prompted to create
a new user at the end of the firstboot assistant, when you enter your password,
you will be warned if it's too weak.
You can choose to _force_ to use a weak password and continue, however if your
password is less than N (6, I think) chars long you will receive a second
warning now in the form of an error.
This is an inconsistency, if you allow me to force the use of a weak password,
why hit me again with another check?

The process should _first_ check for length, then for weakness. That way
passwords less than N chars are not allowed ever, and just _then_ you can force
a weak password

How reproducible:
Boot for the first time, create a new user with a weak password that is also
shorter than the minimum char length
Comment 1 Chris Lumens 2007-10-10 09:45:47 EDT

*** This bug has been marked as a duplicate of 296651 ***

Note You need to log in before you can comment on or make changes to this bug.