Bug 325711 - yum info crashes on any package
yum info crashes on any package
Status: CLOSED DUPLICATE of bug 252136
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 19:15 EDT by Milos Jakubicek
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 21:31:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Jakubicek 2007-10-09 19:15:24 EDT
Description of problem: Yum info crashes and gives following traceback on any
package:

Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 282, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 168, in doCommand
    rip = base.listPkgs(ypl.installed, 'Installed Packages', basecmd)
  File "/usr/share/yum-cli/output.py", line 129, in listPkgs
    self.infoOutput(pkg)
  File "/usr/share/yum-cli/output.py", line 99, in infoOutput
    print _("Summary: %s") % enc(pkg.summary)
  File "/usr/share/yum-cli/output.py", line 86, in enc
    t = gettext.dgettext(d, s)
  File "/usr/lib64/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib64/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib64/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'

Version-Release number of selected component (if applicable):
yum-3.2.6-1.fc7

How reproducible:
yum info [any_package]
  
Actual results:

Crashes with traceback.

Expected results:

Should output package information.
Comment 1 Seth Vidal 2007-10-09 19:29:52 EDT
what's your locale set to so I can test this?

Comment 2 Jeremy Katz 2007-10-09 21:31:10 EDT

*** This bug has been marked as a duplicate of 252136 ***
Comment 3 Milos Jakubicek 2007-10-10 06:26:05 EDT
My locale is cs_CZ.UTF-8. With en_US.UTF-8 everything works fine, so it really
seems to be duplicate as marked (sorry for that, I only searched for bugs in the
"yum" component before filing the bug).

Note You need to log in before you can comment on or make changes to this bug.