Bug 252136 - Can not list packages on Bengali (LANG=bn_IN.UTF-8) desktop.
Can not list packages on Bengali (LANG=bn_IN.UTF-8) desktop.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: James Antill
Fedora Extras Quality Assurance
http://bugs.python.org/issue1475523
:
: 254103 325711 355091 359741 365061 367651 368031 370861 374401 377311 381971 384131 386651 387111 pirut 388341 389271 389531 390861 391101 392481 392841 394051 394711 394841 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-08-14 02:14 EDT by Debarshi Ray
Modified: 2007-11-30 17:12 EST (History)
27 users (show)

See Also:
Fixed In Version: 2.5-15.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 22:30:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Debarshi Ray 2007-08-14 02:14:27 EDT
Description of problem:

Pirut crashes on every attempt to list the packages (not groups) on Fedora's
Bengali (LANG=bn_IN.UTF-8) desktop.


Version-Release number of selected component (if applicable):

pirut-1.3.10-1


How reproducible:

Launch Pirut with LANG=bn_IN.UTF-8, and chose the 'List' tab or try to view the
packages within each group.

Steps to Reproduce:

1. Launch Pirut as: # LANG=bn_IN.UTF-8 pirut
2. Click the 'List' tab.

  
Actual results:

Pirut crashes. Traceback given below.


Expected results:

Available and installed packages should be listed as they are with LANG=en_US.UTF-8.


Additional info:

Here is the backtrace obtained after the crash:
http://rishi.fedorapeople.org/pirut.trace

There is no such problem with versions 1.3.9 and below. Here is a 'diff -urNp'
between versions 1.3.9 and 1.3.10:
http://rishi.fedorapeople.org/pirut.diff
Comment 1 Sankarshan Mukhopadhyay 2007-08-14 05:25:16 EDT
Yes, I can confirm this as happening with regularity. Obtained trace is similar
to http://rishi.fedorapeople.org/pirut.trace
Comment 2 Sankarshan Mukhopadhyay 2007-08-14 05:29:56 EDT
Tested with the French locale, Pirut works as expected.
Comment 3 Sankarshan Mukhopadhyay 2007-08-14 05:35:49 EDT
Crashes with similar trace for the Bengali (bn_BD) locale. Does that help in
going along the debugging of this issue ?
Comment 4 Runa Bhattacharjee 2007-08-14 05:52:09 EDT
Tested with the following locales:

bn=failed
bn_IN = failed
hi= failed
gu=failed
el=failed
en_US=success

Doesnt seem to be a translation bug.
Comment 5 Jeremy Katz 2007-08-14 10:58:57 EDT
It's a bug in python's gettext module.  With specspo installed, do 
  LANG=bn_IN.UTF-8 python -c 'import gettext; 
   print gettext.dgettext("redhat-dist", "foo")'

Previously reported upstream at
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=1448060&group_id=5470
but no real resolution from it
Comment 6 Debarshi Ray 2007-08-22 18:33:34 EDT
Here is what I get.

[rishi@ginger noarch]$ LANG=bn_IN.UTF-8 python -c 'import gettext; 
> print gettext.dgettext("redhat-dist", "foo")'
Traceback (most recent call last):
  File "<string>", line 2, in <module>
  File "/usr/lib/python2.5/gettext.py", line 530, in dgettext
    codeset=_localecodesets.get(domain))
  File "/usr/lib/python2.5/gettext.py", line 478, in translation
    t = _translations.setdefault(key, class_(open(mofile, 'rb')))
  File "/usr/lib/python2.5/gettext.py", line 180, in __init__
    self._parse(fp)
  File "/usr/lib/python2.5/gettext.py", line 313, in _parse
    v = v.split(';')
AttributeError: 'list' object has no attribute 'split'
[rishi@ginger noarch]$ 
Comment 7 Debarshi Ray 2007-08-22 18:35:46 EDT
1. Can we have the patch from
https://sourceforge.net/tracker/?func=detail&atid=105470&aid=1448060&group_id=5470
in Fedora?

2. pirut-1.3.9 does not have this issue with the same Python package. Can we
revert whatever changed since 1.3.9 in order to have a temporary fix?
Comment 8 Jeremy Katz 2007-08-22 20:55:52 EDT
(In reply to comment #7)
> 1. Can we have the patch from
> https://sourceforge.net/tracker/?func=detail&atid=105470&aid=1448060&group_id=5470
> in Fedora?

The comments imply that the patch is wrong, so taking it directly is likely a
bad idea.

> 2. pirut-1.3.9 does not have this issue with the same Python package. Can we
> revert whatever changed since 1.3.9 in order to have a temporary fix?

Doing so breaks a number of other translation cases, so really isn't ideal
either.  We really just need to fix the bug in python here; the patch is
probably a good start for when James gets back from vacation or I'll end up
taking a look if it's still lingering around test3.
Comment 9 Jeremy Katz 2007-08-24 09:53:49 EDT
*** Bug 254103 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2007-09-10 11:35:08 EDT
New URL for this upstream is http://bugs.python.org/issue1448060 (also,
http://bugs.python.org/issue1475523 is relevant)
Comment 11 Jeremy Katz 2007-09-10 11:43:39 EDT
And applied something of a fix for our python package.  I don't see how it can
break after reading the mo file specification for a bit and the gettext code
Comment 12 Jeremy Katz 2007-10-09 21:31:11 EDT
*** Bug 325711 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2007-10-31 09:38:22 EDT
*** Bug 359741 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2007-11-01 13:55:33 EDT
*** Bug 355091 has been marked as a duplicate of this bug. ***
Comment 15 Nicola Soranzo 2007-11-02 12:09:16 EDT
This bug is still present in Fedora 7, and also for lang=it.

Nicola
Comment 16 Sascha Harusta 2007-11-03 06:02:49 EDT
*** Bug 365061 has been marked as a duplicate of this bug. ***
Comment 17 Jeremy Katz 2007-11-06 00:41:49 EST
*** Bug 367651 has been marked as a duplicate of this bug. ***
Comment 18 Debarshi Ray 2007-11-06 01:41:45 EST
After updating python (# yum update python*) pirut-1.3.25-2 seems to work fine
for LANG=bn_IN.UTF-8.
Comment 19 marco bernardi 2007-11-06 04:02:45 EST
After general update of november 6 (Kernel 2.6.23.1-21.fc7) 

for LANG=it_IT 

yum info <something> => crash

Comment 20 Thomas Müller 2007-11-06 06:14:22 EST
LANG=de_DE.UTF-8 also causes 'yum info' to crash
Comment 21 Jeremy Katz 2007-11-06 09:01:40 EST
*** Bug 368031 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2007-11-09 09:14:59 EST
*** Bug 370861 has been marked as a duplicate of this bug. ***
Comment 23 shrek-m 2007-11-09 10:11:38 EST
thanks.

for F7  python-*2.5-15.fc7 is ok
http://koji.fedoraproject.org/koji/buildinfo?buildID=23519

# rpm -qa python* | grep 2.5-15
python-devel-2.5-15.fc7
python-libs-2.5-15.fc7
python-2.5-15.fc7

not yet in f7 updates-testing :(
Comment 24 James Antill 2007-11-09 10:48:24 EST
 Yeh, I know, I've requested it ... but it hasn't turned up yet (I assume Fed-8
is slowing the process down).
 Anyway feel free to visit:

https://admin.fedoraproject.org/updates/F7/pending/python-2.5-15.fc7

...and give it some karma.
Comment 25 Fedora Update System 2007-11-09 18:51:13 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python'
Comment 26 Jeremy Katz 2007-11-12 11:03:02 EST
*** Bug 374401 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Katz 2007-11-12 11:30:17 EST
*** Bug 377311 has been marked as a duplicate of this bug. ***
Comment 28 marco bernardi 2007-11-13 13:56:07 EST
OK !
for me (LANG it_IT.UTF-8) it works

Thanks

Marco
Comment 29 Jeremy Katz 2007-11-14 10:16:09 EST
*** Bug 381971 has been marked as a duplicate of this bug. ***
Comment 30 Jeremy Katz 2007-11-15 20:09:25 EST
*** Bug 384131 has been marked as a duplicate of this bug. ***
Comment 31 Jeremy Katz 2007-11-16 11:19:29 EST
*** Bug 387111 has been marked as a duplicate of this bug. ***
Comment 32 Jeremy Katz 2007-11-19 11:17:34 EST
*** Bug 388201 has been marked as a duplicate of this bug. ***
Comment 33 Jeremy Katz 2007-11-19 11:18:52 EST
*** Bug 388341 has been marked as a duplicate of this bug. ***
Comment 34 Jeremy Katz 2007-11-19 11:20:15 EST
*** Bug 389271 has been marked as a duplicate of this bug. ***
Comment 35 Jeremy Katz 2007-11-19 11:20:44 EST
*** Bug 389531 has been marked as a duplicate of this bug. ***
Comment 36 Jeremy Katz 2007-11-19 14:20:56 EST
*** Bug 386651 has been marked as a duplicate of this bug. ***
Comment 37 Jeremy Katz 2007-11-19 14:21:14 EST
*** Bug 390861 has been marked as a duplicate of this bug. ***
Comment 38 Jeremy Katz 2007-11-19 17:29:08 EST
*** Bug 391101 has been marked as a duplicate of this bug. ***
Comment 39 Jeremy Katz 2007-11-20 09:57:43 EST
*** Bug 392481 has been marked as a duplicate of this bug. ***
Comment 40 Jeremy Katz 2007-11-20 14:49:06 EST
*** Bug 392841 has been marked as a duplicate of this bug. ***
Comment 41 Jeremy Katz 2007-11-21 13:42:22 EST
*** Bug 394711 has been marked as a duplicate of this bug. ***
Comment 42 Jeremy Katz 2007-11-21 15:02:23 EST
*** Bug 394051 has been marked as a duplicate of this bug. ***
Comment 43 James Antill 2007-11-21 15:37:56 EST
*** Bug 394841 has been marked as a duplicate of this bug. ***
Comment 44 Fedora Update System 2007-11-21 22:29:51 EST
python-2.5-15.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 45 Sankarshan Mukhopadhyay 2007-11-23 23:40:05 EST
Works for bn_IN and bn. Checked for other Indic locales too and works_for_me.
Thanks :)
Comment 46 peterhoffm 2007-11-24 07:50:38 EST
german language also works very well!

Note You need to log in before you can comment on or make changes to this bug.