Bug 325771 - (UpdateError) TB2a40cfda misc.py:349:bunzipFile:IOError: invalid data stream
TB2a40cfda misc.py:349:bunzipFile:IOError: invalid data stream
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 349241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 21:49 EDT by Joe Earl
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.2.7-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:15:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bug report copied from error (1.84 KB, application/octet-stream)
2007-10-09 21:49 EDT, Joe Earl
no flags Details

  None (edit)
Description Joe Earl 2007-10-09 21:49:13 EDT
Description of problem:  Trying to apply first updates after initial
installation but shutdown during update


Version-Release number of selected component (if applicable):


How reproducible: repeated several attempts


Steps to Reproduce:
1. View Updates
2. Shows 205 updates available
3. Click Apply Updates
4. Resolves dependencies
  
Actual results:
Component: Software Updater
Summary: TB2a40cfda misc.py:349:bunzipFile:IOError: invalid data stream

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 718, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 481, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 549, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 794, in resolveDeps
    deps = self._mytsCheck()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 775, in _mytsCheck
    ret.extend(self._checkRemove(txmbr))
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1003, in
_checkRemove
    for f in newpo.filelist:
  File "/usr/lib/python2.5/site-packages/yum/packages.py", line 367, in <lambda>
    filelist = property(fget=lambda self: self.returnFileEntries(ftype='file'))
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 171, in
returnFileEntries
    self._loadFiles()
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 117, in _loadFiles
    self.sack.populate(self.repo, mdtype='filelists')
  File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 156, in populate
    misc.bunzipFile(db_fn, db_un_fn)
  File "/usr/lib/python2.5/site-packages/yum/misc.py", line 349, in bunzipFile
    data = s_fn.read(1024000)
IOError: invalid data stream

Local variables in innermost frame:
dest: //var/cache/yum/updates/filelists.sqlite
source: //var/cache/yum/updates/filelists.sqlite.bz2
destination: <open file '//var/cache/yum/updates/filelists.sqlite', mode 'w' at
0xd90f6e0>
s_fn: <bz2.BZ2File object at 0xd90f650>

Expected results:


Additional info:
Comment 1 Joe Earl 2007-10-09 21:49:13 EDT
Created attachment 222101 [details]
bug report copied from error
Comment 2 Jeremy Katz 2007-10-09 22:19:56 EDT
Running 'yum clean all' and then running again should fix things; this looks
like a corrupt download.  And I've fixed upstream to catch the error better
Comment 3 Fedora Update System 2007-10-15 17:24:27 EDT
yum-3.2.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum'
Comment 4 Fedora Update System 2007-10-24 03:15:31 EDT
yum-3.2.7-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Jeremy Katz 2007-10-31 09:39:47 EDT
*** Bug 349241 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.