Bug 325931 - RFE: provide boost tools
RFE: provide boost tools
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: boost (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Benjamin Kosnik
Fedora Extras Quality Assurance
:
: 317381 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-10 04:05 EDT by Thomas Moschny
Modified: 2013-08-09 01:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 09:42:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Moschny 2007-10-10 04:05:07 EDT
Boost contains a number of tools, that are currently not packaged. See 
http://www.boost.org/tools/. This page states: that "these tools [...] are 
part of the regular Boost distribution."

There's already a request for boost-jam (bug #317381), but other tools like 
bcp and wave should also be made available. Not all tools need to be in their 
own rpm, though. bcp for example is a very specialized tool that could be 
added to boost-devel.

Version-Release number of selected component (if applicable):
boost-1.33.1-13.fc7
boost-devel-1.33.1-13.fc7
Comment 1 Petr Machata 2007-10-10 09:42:30 EDT
Boost tools are intended for development of boost itself, so packaging them for
boost is similar to providing package with sources.  They are not necessary for
applications that use boost, nor are they necessary for development of these
applications.  As such they belong to version control system, or .src.rpm
package, where we currently have them.

Moreover, unique selling point of boost is necessarily in libraries, not so much
in tools.  Distribution of development forces matches this.  If there was a
proper upstream for these tools, with boost being their primary consumer, then
packaging would be an option.  As it is, boost tools are basically ad-hoc set of
in-house utilities.

And, as a last straw, boost community itself seems to be pretty unsure about
their own tools.  http://lists.boost.org/boost-build/2007/10/17426.php has a
nice, recent argument that doesn't exactly fill me with confidence that the
tools are actually maintainable at all.  If the upstream drops or changes them
incompatibly one day, we will either have to fix every package that depends on
boost-tools, or maintain given tool ourselves for every new Fedora release
forever.  That doesn't compute.

Sorry, wontfix.
Comment 2 Petr Machata 2007-10-10 09:43:28 EDT
*** Bug 317381 has been marked as a duplicate of this bug. ***
Comment 3 Stou Sandalski 2009-10-06 17:33:19 EDT
This bug should be reexamined because Jam is clearly the recommended, if not required, way of creating Python bindings using Boost-Python (See: http://www.boost.org/doc/libs/1_40_0/libs/python/doc/tutorial/doc/html/python/hello.html) 

In other words the boost-devel package is crippled in terms of Boost-Python
Comment 4 Benjamin Kosnik 2010-01-25 13:49:41 EST
Again, WONTFIX due to upstream efforts to move to cmake.

Note You need to log in before you can comment on or make changes to this bug.