Bug 327141 - Spacebar causes exception when used for package deselection in graphical installation
Spacebar causes exception when used for package deselection in graphical inst...
Status: CLOSED DUPLICATE of bug 336791
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-10 22:35 EDT by Vincent Murphy
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-14 14:53:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
anaconda crash log (65.77 KB, text/plain)
2007-11-14 14:49 EST, Andreas Thienemann
no flags Details

  None (edit)
Description Vincent Murphy 2007-10-10 22:35:45 EDT
Description of problem:
During installation (graphical mode) and customisation of packages, when
Optional Packages dialogue is open and a package selected, pressing the space
bar causes an immediate exception and crash requiring a reboot.

Version-Release number of selected component (if applicable):
As bundled.

How reproducible:
Twice tested, twice reproducible.

Steps to Reproduce:
1. Start installation process with anaconda, graphical mode
2. Select a package with optional components
3. View optional components and with one selected, press space bar
Actual results:
Exception and crash.

Expected results:
Component to become unchecked.

Additional info:
Comment 1 Jeremy Katz 2007-10-11 17:07:36 EDT
I'm not reproducing this here -- can you attach the traceback that you received?
Comment 2 Joe Rozner 2007-11-08 02:14:35 EST
I'm reproducing this on the release version. how can I get the traceback during
the install?
Comment 3 Vincent Murphy 2007-11-08 02:36:15 EST
Would be glad of that information as well, from the exception I can't go
anywhere but a hard reboot.
Comment 4 Chris Lumens 2007-11-12 13:46:48 EST
http://fedoraproject.org/wiki/Anaconda/BugReporting describes how to get the
exception report.  I am also unable to reproduce this issue.  Does it happen
with only a certain package, or is it different ones every time?
Comment 5 Joe Rozner 2007-11-12 13:51:16 EST
I tried it with a couple packages when installing and had it happen every time,
so I'm assuming it's not specific to certain packages.
Comment 6 Andreas Thienemann 2007-11-14 14:48:49 EST
Okay, some information about reproducing this:

Go to the package selection by chosing "customize now". Select any group
offering further customizazion, click on "Optional packages", click select or
deselect any package and press the cursor key to the right.

Your cursor should now be on the description field of the package signified by
having a dashed box around the selection.

Now press space and voila, you've got a crash.

Crashdump is attached.
Comment 7 Andreas Thienemann 2007-11-14 14:49:36 EST
Created attachment 258691 [details]
anaconda crash log
Comment 8 Chris Lumens 2007-11-14 14:53:27 EST
Duping into the future...

*** This bug has been marked as a duplicate of 336791 ***

Note You need to log in before you can comment on or make changes to this bug.