Bug 32803 - Patching config.h fails on RH6.1
Patching config.h fails on RH6.1
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: ntp (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-23 02:00 EST by kenneth_porter
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 02:00:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kenneth_porter 2001-03-23 02:00:36 EST
Trying to build ntp-4.0.99k-13 on RH6.1 (glibc-2.1.2-11).Patch config.h for glibc fails because config.h has /* #undef SYM */, not #define SYM 1.  
Is patch unnecessary with this glibc? I patched the spec file to continue if the patch fails (ie. "|| echo 'Patch failed'") so I could continue.
Comment 1 Preston Brown 2001-03-26 10:33:14 EST
we make no guarantees that newer packages, designed for newer systems with 
newer library combinations, will build on older systems.  Yes, this is because 
7.x runs glibc 2.1 or 2.2, not glibc 2.0.
Comment 2 kenneth_porter 2001-06-27 23:36:23 EDT
Duplicate of bug 35362. Fix provided there.

Note You need to log in before you can comment on or make changes to this bug.