Bug 32808 - ssh seems to loose bytes on stdout
ssh seems to loose bytes on stdout
Status: CLOSED DUPLICATE of bug 24293
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2001-03-23 04:47 EST by Michal Jaegermann
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-04-02 20:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-03-23 04:47:35 EST
With openssh-2.5.2p1-1 and tar-1.13.19-4 I consistently see the

ssh toaster "cd /tmp ; tar --totals -cf - junk/cy*dev*" | tar -xv
Total bytes written: 317440 (310kB, ?B/s)
tar: Unexpected EOF in archive
tar: Unexpected EOF in archive
tar: Error is not recoverable: exiting now

An output is always 280064 (01043000 octal, 0x44600 hex) bytes

This does not happen with every file (weird?) but with
cyrus-sasl-devel-1.5.24-17.i386.rpm I have 100% hit rate.

'toaster' is another machine on a local network and
'scp toaster:/junk/cyrus-sasl-devel-1.5.24-17.i386.rpm .' works.
Also transfering this file between local directories via
tar piped to another tar reading stdin works.

The same happened with glibc-2.2.2-8 and glibc-2.2.2-7 (I backed off
due to amd problems).
Comment 1 Nalin Dahyabhai 2001-04-02 20:16:40 EDT
What version of the server is toaster running?  If 2.3.0p1, then this is a
duplicate of #24293.
Comment 2 Michal Jaegermann 2001-04-02 20:41:04 EDT
At the time of that report this was indeed 2.3.0p1; but right now it is
2.5.2p2 and the trouble, at least using these particular files, is gone.
It looks that you are right the problem was really on the other side
although I did not try every available file. :-)
Comment 3 Nalin Dahyabhai 2001-04-02 21:51:49 EDT
Excellent.  I'll close this bug then.

*** This bug has been marked as a duplicate of 24293 ***

Note You need to log in before you can comment on or make changes to this bug.