Bug 24293 - ssh: data goes missing
Summary: ssh: data goes missing
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard: Florence Gold
Keywords:
: 24691 32808 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-18 16:46 UTC by Tim Waugh
Modified: 2007-04-18 16:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-03 09:01:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Tim Waugh 2001-01-18 16:46:39 UTC
[root@turmoil /root]# dd if=/dev/zero bs=1k count=100 | wc
100+0 records in
100+0 records out
      0       0  102400
[root@turmoil /root]# ssh localhost dd if=/dev/zero bs=1k count=100 | wc
Password:
      0       0   65536

Um.. (this was from a tip-off on linux-kernel)

Comment 1 Tim Waugh 2001-01-18 16:47:27 UTC
Oh yeah, this is with:

openssh-2.3.0p1-10
openssh-server-2.3.0p1-10
openssh-clients-2.3.0p1-10


Comment 2 Glen Foster 2001-01-18 21:24:50 UTC
This defect is considered MUST-FIX for Florence Gold release

Comment 3 Pekka Savola 2001-01-20 08:03:33 UTC
This is caused by the same thing as #21607.

This can be solved by reverting a fix or upgrading to latest snapshots, but 
the other problem with hanging connections (#19837) (sleep10& exit; service httpd restart, etc.)
will then come up.

It's one or the other, unless someone figures a way to fix this properly :-(.  There's info about these
issues in the reports I think, as well as current OpenSSH CVS TODO list.





Comment 4 Nalin Dahyabhai 2001-01-23 18:58:34 UTC
*** Bug 24691 has been marked as a duplicate of this bug. ***

Comment 5 Pekka Savola 2001-01-23 19:07:50 UTC
Note: there's a workaround for bash by Damien Miller for #19837:

shopt -s huponexit



Comment 6 Brian Brock 2001-02-01 00:22:37 UTC
In addition to the above, I'm getting the following output with
openssh-2.3.0p1-14 (logged in as user test across the network):

[test@localhost test]$ ssh localhost dd if=/dev/zero bs=1k count=100 | wc
Password: 
select: Bad file descriptor
      0       0       0

The complaint about select isn't listed above

Comment 7 Pekka Savola 2001-02-02 23:53:06 UTC
Brock, do you have  a funky .bashrc or .bash_profile which prints out stuff when you log in?

Or anything that'd generate output in stderr?



Comment 8 Nalin Dahyabhai 2001-02-20 22:58:58 UTC
2.5.1p1 should show up in Raw Hide soon.

Comment 9 Brian Brock 2001-02-21 17:51:27 UTC
No, the user test doesn't have anything unusual in .bashrc, .bash_profile, or
any similar startup files.  In fact, they're unmodified from a stock install, so
they should be identical to the copies in /etc/skel (the user test was created
after system installation of the beta.

Double-checking the .bashrc and other files (by sourcing them as the logged-in
user) didn't reveal any output to stderr.  

I'm going to begin re-testing with the latest tree (qa0221.0) today, which
includes the new openssh-2.5.1p1-1.

Comment 10 Nalin Dahyabhai 2001-02-22 22:17:34 UTC
I highly suspect login scriptlet wackiness is to blame here.  The
closing-too-soon problem in 2.3.0p1 is correctly reverted in 2.5.1p1, but we get
the hang-on-exit (which affects rsh, too) when we do that.

Comment 11 Nalin Dahyabhai 2001-02-28 22:35:34 UTC
I'm beginning to suspect that this is endemic to the rsh and friends work,
because the hang appears both on an OpenBSD server running OpenSSH 2.5.1, and on
a Linux box using regular unencrypted rsh.

Comment 12 Nalin Dahyabhai 2001-04-03 01:51:44 UTC
*** Bug 32808 has been marked as a duplicate of this bug. ***

Comment 13 Tomas Mraz 2005-02-03 09:01:54 UTC
This is fixed as the patch that caused this regression was removed
long ago.



Note You need to log in before you can comment on or make changes to this bug.