This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 328801 - exception in pirut in Software Updater, while Retrieving software information
exception in pirut in Software Updater, while Retrieving software information
Status: CLOSED DUPLICATE of bug 325901
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-11 21:23 EDT by Will Strang
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 10:16:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
traceback from Software Updater Exception Occurred dialog (2.61 KB, text/plain)
2007-10-11 21:23 EDT, Will Strang
no flags Details

  None (edit)
Description Will Strang 2007-10-11 21:23:02 EDT
Description of problem:
In every Software Updater run after OS install, an unhandled exception occurs in
pirut, immediately after starting "Retrieving software information".

Version-Release number of selected component (if applicable):
pirut-1.3.20-1.fc8

How reproducible:
It happens in every Software Updater run.  I reinstalled the OS from the i386
DVD, and it still happens.

Steps to Reproduce:
1. Install Fedora 8 test 3 on /dev/sda.
2. Reboot, once or more, and login to X as the non-root user.
3. Run Software Updater and enter the root password when prompted.
  
Actual results:
An "Exception Occurred" dialog with a Traceback, which is attached.

Expected results:
Software Updater should have run normally and installed 162 updated packages.

Additional info:
Fedora 8 test 3 is installed on the just-added PATA disk /dev/sda, which is
master disk on the second IDE channel.
Fedora 7 has been installed for 6 months on /dev/sdb, which is a SATA disk.

[root@new-host ~]# fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0003de74

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          13      104391   83  Linux
/dev/sda2              14       24321   195254010   8e  Linux LVM

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00002fdd

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          13      104391   83  Linux
/dev/sdb2              14       19457   156183930   8e  Linux LVM

Disk /dev/dm-0: 197.8 GB, 197803376640 bytes
255 heads, 63 sectors/track, 24048 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

Disk /dev/dm-1 doesn't contain a valid partition table

Disk /dev/dm-2: 157.8 GB, 157873602560 bytes
255 heads, 63 sectors/track, 19193 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-2 doesn't contain a valid partition table

Disk /dev/dm-3: 2013 MB, 2013265920 bytes
255 heads, 63 sectors/track, 244 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

Disk /dev/dm-3 doesn't contain a valid partition table
Comment 1 Will Strang 2007-10-11 21:23:02 EDT
Created attachment 224921 [details]
traceback from Software Updater Exception Occurred dialog
Comment 2 Jeremy Katz 2007-10-12 10:16:46 EDT

*** This bug has been marked as a duplicate of 325901 ***

Note You need to log in before you can comment on or make changes to this bug.