Bug 328991 - undefined struct __kernel_sockaddr_storage in netinet/tcp.h
undefined struct __kernel_sockaddr_storage in netinet/tcp.h
Status: CLOSED DUPLICATE of bug 327871
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 01:11 EDT by Alexandre Oliva
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 03:00:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2007-10-12 01:11:35 EDT
The newly-added struct tcp_md5sig in /usr/include/netinet/tcp.h has a member of
the incomplete type struct __kernel_sockaddr_storage without including the
header that defines this type.  This breaks the GCC trunk libjava build
(gnu/java/net/natPlainSocketImpl.cc ->
$srcdir/.../libjava/gnu/java/net/natPlainSocketImplPosix.cc, and probably
anything else that includes this header without including
/usr/include/linux/socket.h before.

Version-Release number of selected component (if applicable):
glibc-headers-2.6.90-18
Comment 1 Jakub Jelinek 2007-10-12 03:00:10 EDT

*** This bug has been marked as a duplicate of 327871 ***

Note You need to log in before you can comment on or make changes to this bug.