Bug 327871 - Rhythmbox fails to build because of libsoup
Rhythmbox fails to build because of libsoup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
: Regression
: 328991 (view as bug list)
Depends On:
Blocks: 242260
  Show dependency treegraph
 
Reported: 2007-10-11 12:04 EDT by Bastien Nocera
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 03:00:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-10-11 12:04:19 EDT
gcc -DHAVE_CONFIG_H -I. -I../.. -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DG_LOG_DOMAIN=\"Rhythmbox\" -I../.. -I../../lib -I../../metadata -I../../player
-I../../rhythmdb -I../../widgets -I../../sources -I../../iradio -I../../podcast
-I../../remote -I../../remote -I../../lib -I../../plugins -I../../shell
-I../../plugins -DPIXMAP_DIR=\"/usr/share/pixmaps\"
-DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\"
-I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_REENTRANT -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libart-2.0
-I/usr/include/gconf/2 -I/usr/include/libglade-2.0 -I/usr/include/libxml2
-I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2
-D_XOPEN_SOURCE -D_BSD_SOURCE -I/usr/include/gnome-keyring-1
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
rb-daap-share.lo -MD -MP -MF .deps/rb-daap-share.Tpo -c rb-daap-share.c  -fPIC
-DPIC -o .libs/rb-daap-share.o
In file included from /usr/include/libsoup-2.2/libsoup/soup-portability.h:21,
                 from /usr/include/libsoup-2.2/libsoup/soup-address.h:11,
                 from rb-daap-share.c:31:
/usr/include/netinet/tcp.h:236: error: field 'tcpm_addr' has incomplete type
 gcc -DHAVE_CONFIG_H -I. -I../.. -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DG_LOG_DOMAIN=\"Rhythmbox\" -I../.. -I../../lib -I../../metadata -I../../player
-I../../rhythmdb -I../../widgets -I../../sources -I../../iradio -I../../podcast
-I../../remote -I../../remote -I../../lib -I../../plugins -I../../shell
-I../../plugins -DPIXMAP_DIR=\"/usr/share/pixmaps\"
-DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\"
-I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_REENTRANT -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libart-2.0
-I/usr/include/gconf/2 -I/usr/include/libglade-2.0 -I/usr/include/libxml2
-I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2
-D_XOPEN_SOURCE -D_BSD_SOURCE -I/usr/include/gnome-keyring-1
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
rb-daap-sharing.lo -MD -MP -MF .deps/rb-daap-sharing.Tpo -c rb-daap-sharing.c -o
rb-daap-sharing.o >/dev/null 2>&1
make[4]: *** [rb-daap-share.lo] Error 1
make[4]: *** Waiting for unfinished jobs....
 gcc -DHAVE_CONFIG_H -I. -I../.. -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DG_LOG_DOMAIN=\"Rhythmbox\" -I../.. -I../../lib -I../../metadata -I../../player
-I../../rhythmdb -I../../widgets -I../../sources -I../../iradio -I../../podcast
-I../../remote -I../../remote -I../../lib -I../../plugins -I../../shell
-I../../plugins -DPIXMAP_DIR=\"/usr/share/pixmaps\"
-DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\"
-I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_REENTRANT -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libart-2.0
-I/usr/include/gconf/2 -I/usr/include/libglade-2.0 -I/usr/include/libxml2
-I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2
-D_XOPEN_SOURCE -D_BSD_SOURCE -I/usr/include/gnome-keyring-1
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
rb-daap-source.lo -MD -MP -MF .deps/rb-daap-source.Tpo -c rb-daap-source.c -o
rb-daap-source.o >/dev/null 2>&1
 gcc -DHAVE_CONFIG_H -I. -I../.. -DGNOMELOCALEDIR=\"/usr/share/locale\"
-DG_LOG_DOMAIN=\"Rhythmbox\" -I../.. -I../../lib -I../../metadata -I../../player
-I../../rhythmdb -I../../widgets -I../../sources -I../../iradio -I../../podcast
-I../../remote -I../../remote -I../../lib -I../../plugins -I../../shell
-I../../plugins -DPIXMAP_DIR=\"/usr/share/pixmaps\"
-DSHARE_DIR=\"/usr/share/rhythmbox\" -DDATADIR=\"/usr/share\"
-I/usr/include/libsoup-2.2 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libxml2 -D_REENTRANT -I/usr/include/glib-2.0
-I/usr/lib/glib-2.0/include -DORBIT2=1 -pthread -I/usr/include/gtk-2.0
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo
-I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/libgnomeui-2.0 -I/usr/include/libgnome-2.0
-I/usr/include/libbonoboui-2.0 -I/usr/include/libgnomecanvas-2.0
-I/usr/include/gnome-vfs-2.0 -I/usr/lib/gnome-vfs-2.0/include
-I/usr/include/libbonobo-2.0 -I/usr/include/orbit-2.0
-I/usr/include/bonobo-activation-2.0 -I/usr/include/libart-2.0
-I/usr/include/gconf/2 -I/usr/include/libglade-2.0 -I/usr/include/libxml2
-I/usr/include/gnome-vfs-module-2.0 -pthread -I/usr/include/gstreamer-0.10
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2
-D_XOPEN_SOURCE -D_BSD_SOURCE -I/usr/include/gnome-keyring-1
-I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -O2 -g -pipe -Wall
-Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4
-m32 -march=i386 -mtune=generic -fasynchronous-unwind-tables -MT
rb-daap-plugin.lo -MD -MP -MF .deps/rb-daap-plugin.Tpo -c rb-daap-plugin.c -o
rb-daap-plugin.o >/dev/null 2>&1
mv -f .deps/rb-daap-sharing.Tpo .deps/rb-daap-sharing.Plo
mv -f .deps/rb-daap-source.Tpo .deps/rb-daap-source.Plo
mv -f .deps/rb-daap-plugin.Tpo .deps/rb-daap-plugin.Plo
make[4]: Leaving directory `/builddir/build/BUILD/rhythmbox-0.11.2/plugins/daap'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/builddir/build/BUILD/rhythmbox-0.11.2/plugins/daap'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/builddir/build/BUILD/rhythmbox-0.11.2/plugins'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/builddir/build/BUILD/rhythmbox-0.11.2'
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.52359 (%build)
Comment 1 Bastien Nocera 2007-10-11 12:06:18 EDT
See for details:
http://koji.fedoraproject.org/koji/getfile?taskID=191414&name=build.log
Comment 2 Matthew Barnes 2007-10-11 13:12:45 EDT
Fixed in libsoup by explicitly including <linux/socket.h>.

But now Evolution is showing the same bug, so this is definitely not a libsoup
problem.  Reassigning to glibc.
Comment 3 Matthew Barnes 2007-10-11 13:15:03 EDT
Relevant IRC discussion from #desktop:

<mclasen> looks more like a glibc issue ?
<mclasen> in netinet/tcp.h
<hadess> possibly
<hadess> or brokenness in the libsoup headers
<mclasen> it is missing the definition for struct __kernel_sockaddr_storage
<danw> it's just #including them... aren't headers supposed to let you include
them in any order these days?
<danw> probably moving the <sys/socket.h> include before the two netinet
includes will fix it?
<mclasen> yeah, looks like it, socket.h defines __kernel_sockaddr_storage
Comment 4 Jakub Jelinek 2007-10-11 13:21:55 EDT
This is fixed in glibc-2.6.90-19 which is building in koji ATM.
Comment 5 Jakub Jelinek 2007-10-12 03:00:11 EDT
*** Bug 328991 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Jelinek 2007-10-12 03:00:42 EDT
Build finished.

Note You need to log in before you can comment on or make changes to this bug.