Bug 329241 - [PATCH] kernel >= 2.6.22 freezes without pci=nommconf on Intel G31/G33/Q35 chipsets
[PATCH] kernel >= 2.6.22 freezes without pci=nommconf on Intel G31/G33/Q35 ch...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 05:03 EDT by Kir Kolyshkin
Modified: 2008-01-14 13:42 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.23.1-42.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-14 13:42:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (2.28 KB, patch)
2007-10-12 12:57 EDT, Kir Kolyshkin
no flags Details | Diff

  None (edit)
Description Kir Kolyshkin 2007-10-12 05:03:35 EDT
Fedora 7 on a new Intel Core 2 Duo box.

Original F7 kernel (2.6.21-1.3194.fc7) boots fine. Doesn't support /dev/agpgart
and new revision of e1000 NIC though, so I have to upgrade.

Updated F7 kernel (2.6.22.9-91.fc7, also tried 2.6.23-1.fc7 from
http://people.redhat.com/davej/kernels/Fedora/fc7/ with the same results)
freezes on boot:

1. With no additional kernel parameters, freezes after printing the following lines:

ACPI: Interpreter enabled
ACPI: (supports S0 S1 S2 S3 S4 S5)
ACPI: Using IOAPIC for interrupt routing
ACPI: PCI root bridge [PCI0] (0000:00)


2. With pci=noacpi, freezes after printing the following lines:

ACPI: Interpreter enabled
ACPI: (supports S0 S1 S2 S3 S4 S5)
ACPI: Using PIC for interrupt routing
Linux Plug and Play Support v0.97 (c) Adam Belay
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp: PnP ACPI: found 11 devices
ACPI: bus type pnp unregistered
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
PCI: Probing PCI hardware


3. With acpi=off, boots and works fine; no second CPU core, no cpufreq...


I guess I should provide some hardware info.

[kir@dhcp0-6 ~]$ sudo /sbin/lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation DRAM Controller [8086:29b0] (rev 02)
00:02.0 VGA compatible controller [0300]: Intel Corporation Integrated Graphics
Controller [8086:29b2] (rev 02)
00:03.0 Communication controller [0780]: Intel Corporation MEI Controller
[8086:29b4] (rev 02)
00:03.2 IDE interface [0101]: Intel Corporation PT IDER Controller [8086:29b6]
(rev 02)
00:03.3 Serial controller [0700]: Intel Corporation Serial KT Controller
[8086:29b7] (rev 02)
00:19.0 Ethernet controller [0200]: Intel Corporation 82566DM-2 Gigabit Network
Connection [8086:10bd] (rev 02)
00:1a.0 USB Controller [0c03]: Intel Corporation USB UHCI Controller #4
[8086:2937] (rev 02)
00:1a.1 USB Controller [0c03]: Intel Corporation USB UHCI Controller #5
[8086:2938] (rev 02)
00:1a.2 USB Controller [0c03]: Intel Corporation USB UHCI Controller #6
[8086:2939] (rev 02)
00:1a.7 USB Controller [0c03]: Intel Corporation USB2 EHCI Controller #2
[8086:293c] (rev 02)
00:1b.0 Audio device [0403]: Intel Corporation HD Audio Controller [8086:293e]
(rev 02)
00:1c.0 PCI bridge [0604]: Intel Corporation PCI Express Port 1 [8086:2940] (rev 02)
00:1c.1 PCI bridge [0604]: Intel Corporation PCI Express Port 2 [8086:2942] (rev 02)
00:1c.2 PCI bridge [0604]: Intel Corporation PCI Express Port 3 [8086:2944] (rev 02)
00:1c.3 PCI bridge [0604]: Intel Corporation PCI Express Port 4 [8086:2946] (rev 02)
00:1c.4 PCI bridge [0604]: Intel Corporation PCI Express Port 5 [8086:2948] (rev 02)
00:1d.0 USB Controller [0c03]: Intel Corporation USB UHCI Controller #1
[8086:2934] (rev 02)
00:1d.1 USB Controller [0c03]: Intel Corporation USB UHCI Controller #2
[8086:2935] (rev 02)
00:1d.2 USB Controller [0c03]: Intel Corporation USB UHCI Controller #3
[8086:2936] (rev 02)
00:1d.7 USB Controller [0c03]: Intel Corporation USB2 EHCI Controller #1
[8086:293a] (rev 02)
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 92)
00:1f.0 ISA bridge [0601]: Intel Corporation LPC Interface Controller
[8086:2914] (rev 02)
00:1f.2 IDE interface [0101]: Intel Corporation 4 port SATA IDE Controller
[8086:2920] (rev 02)
00:1f.3 SMBus [0c05]: Intel Corporation SMBus Controller [8086:2930] (rev 02)
00:1f.5 IDE interface [0101]: Intel Corporation 2 port SATA IDE Controller
[8086:2926] (rev 02)
03:00.0 IDE interface [0101]: Marvell Technology Group Ltd. 88SE6101 single-port
PATA133 interface [11ab:6101] (rev b1)
06:00.0 Ethernet controller [0200]: Intel Corporation 82540EM Gigabit Ethernet
Controller [8086:100e] (rev 02)


Anything more you want to know, any kernel you want me to test -- please ask
Comment 1 yakui.zhao 2007-10-12 05:25:43 EDT
Will you please try it with the boot option of pci=nommconf ?
Thanks.
Comment 2 Kir Kolyshkin 2007-10-12 06:29:46 EDT
(In reply to comment #1)
> Will you please try it with the boot option of pci=nommconf ?

Yep, that works fine for me, thanks! Anything more I can do?
Comment 3 Kir Kolyshkin 2007-10-12 09:33:00 EDT
The following bugs might be related (duplicates?): #251493, #298631, #318941, #
234733, #251245, and maybe some others.

Also, he's the patch fixing the problem: http://lkml.org/lkml/2007/8/25/154
I haven't tried it myself yet, but my colleague is succesfully using Mandriva
2.6.22-based kernel on the same hardware.

Finally, the thread above suggest updating the BIOS. I just did that, taking the
latest BIOS for Intel DQ35MP motherboard, the one with version of 0696 and date
of 2007.1001 (1st of October, i.e. a week old). Unfortunately it didn't fix the
issue.

Please consider taking the patch.
Comment 4 Kir Kolyshkin 2007-10-12 09:34:32 EDT
Sorry here are hyperlinked (I hope) bug numbers...

bug #251493, bug #298631, bug #318941, bug #234733, bug #251245
Comment 5 Kir Kolyshkin 2007-10-12 12:51:07 EDT
(In reply to comment #3)
> Also, he's the patch fixing the problem: http://lkml.org/lkml/2007/8/25/154
> I haven't tried it myself yet

The above patch works for me applied to 2.6.22.9-91.fc7 kernel, i.e. I am now
able to boot w/o adding pci=nommconf flag. Will try on top of 2.6.23 as well.
Comment 6 Kir Kolyshkin 2007-10-12 12:57:38 EDT
Created attachment 225821 [details]
fix

Patch from http://lkml.org/lkml/2007/8/25/154 added as an attachment for your
convenience.
Comment 7 John Summerfield 2007-11-08 20:12:17 EST
Pls rebuild the matching xen kernels for this
Comment 8 Jesse Brandeburg 2007-11-10 02:12:22 EST
I also have this bug with the latest 2.6.23+ kernel from fedora 7 updates, on a
DP35 Intel motherboard (ICH9 chipset).
Comment 9 Kir Kolyshkin 2007-11-10 09:12:30 EST
(In reply to comment #8)
> I also have this bug with the latest 2.6.23+ kernel from fedora 7 updates, on a
> DP35 Intel motherboard (ICH9 chipset).
 
Can you confirm that updating the BIOS to the latest available version doesn't
help? It helps some people (http://lkml.org/lkml/2007/9/27/215) using G35
chipset, but didn't helped me as I reported in comment #3.
Comment 10 Kir Kolyshkin 2007-11-10 09:14:23 EST
I can confirm that F8 kernel boots fine for me without any extra options:

[kir@dhcp0-6 ~]$ uname -a
Linux dhcp0-6.sw.ru 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:18:33 EDT 2007 x86_64
x86_64 x86_64 GNU/Linux

[kir@dhcp0-6 ~]$ cat /proc/cmdline 
ro root=/dev/VolGroup00/LogVol00 vga=0x31b
Comment 11 Jesse Brandeburg 2007-11-11 01:40:01 EST
I can confirm that the bios update didn't help, I forgot to mention that I tried
that first before posting.  I downloaded the latest bios from Intel's support
web page.
Comment 12 Chuck Ebbert 2007-11-12 16:05:08 EST
We have disabled mmconf by default in Fedora 7 and 8, so this is no longer an
issue for Fedora.

Note You need to log in before you can comment on or make changes to this bug.