Bug 329621 - software updater (pup) fails obscurely if network not fully connected.
software updater (pup) fails obscurely if network not fully connected.
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-12 11:43 EDT by Larry Thiel
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-31 09:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback from pup when it failed. (2.12 KB, text/plain)
2007-10-12 11:43 EDT, Larry Thiel
no flags Details

  None (edit)
Description Larry Thiel 2007-10-12 11:43:12 EDT
Description of problem:
When network is alive, but not connected to the world, "software updater" from
systems menu failed on an uncaught exception and asked that I submit a bug report.

Version-Release number of selected component (if applicable):
Name        : pirut                        Relocations: (not relocatable)
Version     : 1.3.9                             Vendor: Fedora Project
Release     : 1.fc7                         Build Date: Mon 23 Jul 2007 10:51:09
AM EDT
I

How reproducible:
Reproduced once until I noticed my router was in limbo and reset it. With a good
connection to the world, all worked well.

Steps to Reproduce:
1.Select "software updater" from the menus as root.
2.
3.
  
Actual results:
Failed as noted above.

Expected results:


Additional info:
This is scarcely a severe bug. But I would think that full network access is a
basic enough thing that it could be checked for and a more informative message
generated if it is not present.
Comment 1 Larry Thiel 2007-10-12 11:43:12 EDT
Created attachment 225671 [details]
traceback from pup when it failed.
Comment 2 Jeremy Katz 2007-10-12 12:51:42 EDT
Can you try with the version of pup in f7-updates-testing and see if things work
better for you with it?
Comment 3 Larry Thiel 2007-10-12 15:10:02 EDT
Sorry. Where do I find f7-updates-testing? 
Comment 4 Jeremy Katz 2007-10-12 16:34:24 EDT
Run (as root)
  yum --enablerepo=updates-testing update pirut
Comment 5 Larry Thiel 2007-10-15 10:21:28 EDT
new pup: (from menu->system->software updater, as root): Hangs
indefinitely showing "Retrieving software information" window. But
since I ran the old pup once this morning with network on, and it
updated the cache, I am not sure that the environments are exactly
parallel. The original bug showed up first thing in the morning, with no
previous  yum (or network) activity. This behaviour is definitely better than
the old, though perhaps still less than ideal.

I will try it again tomorrow morning before any other network activity to see if
it behaves differently when the cache has aged.
Comment 6 Larry Thiel 2007-10-16 11:34:54 EDT
Confirming (and correcting) yesterday's report. When new pup was run on a system
that was booted without proper network connection, it did hang with the
"Retrieving software information" window on screen, but not indefinitely. I went
downstairs for brunch, and when I came back, it had timed out and showed a very
good message about not connecting to server and check network connection. I was
just not patient enough yesterday to wait for the proper diagnostic to show up.
Problem solved.
Comment 7 Jeremy Katz 2007-10-16 14:14:55 EDT
An updated pirut packages is available in the Fedora 7 Updates Testing
repository which should help to resolve this problem.  Can you install this
package by running
   yum --enablerepo=updates-testing update pirut
and then see if you still can reproduce this problem?
Comment 8 Larry Thiel 2007-10-17 10:34:05 EDT
Sorry if I was imprecise in my wording. My reference to "new pup" in comment 5
and 6 was intended to imply the version obtained as per your instructions in
comment 4. So the changes noted in my comment 5 and 6 reflect the improvement I
got when I ran the updated version of pirut. No crash, no complaint about an
uncaught exception, just a hang for an extended time, and eventually an
appropriate error message. So the updated version seems to solve the problem.

While I find the time to get the error message ridiculously long in principle (I
gave up this morning and killed it after about 45 minutes), in practice, even a
less sophisticated owner than I will have no trouble figuring out the problem
without needing an error message. 

I did run the yum command after seeing your comment 7, in case you had made
further changes, but it seems not:
[root@localhost /]# yum --enablerepo=updates-testing update pirut
fedora                    100% |=========================| 2.1 kB    00:00
updates-testing           100% |=========================| 2.3 kB    00:00
updates                   100% |=========================| 2.3 kB    00:01
primary.sqlite.bz2        100% |=========================| 2.2 MB    00:09
Setting up Update Process
Could not find update match for pirut
No Packages marked for Update
Comment 9 Jeremy Katz 2007-12-31 09:49:28 EST
Closing due to inactivity.  If you have further information to add to this
report, please either reopen the bug or file a new one.  

Note You need to log in before you can comment on or make changes to this bug.