Bug 330931 - liveinst fails - sg devices confuse anaconda?
liveinst fails - sg devices confuse anaconda?
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 351221 (view as bug list)
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-13 16:10 EDT by Charles R. Anderson
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-27 15:47:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda traceback (20.37 KB, text/plain)
2007-10-13 16:11 EDT, Charles R. Anderson
no flags Details
.xsession-errors from LiveCD fedora user (1.52 KB, text/plain)
2007-10-13 16:13 EDT, Charles R. Anderson
no flags Details
Dell PowerEdge 2650 scsi info, dmesg, lspci, sg device info (37.07 KB, text/plain)
2007-10-13 16:15 EDT, Charles R. Anderson
no flags Details
output from 'kudzu -p -c HD' (829 bytes, text/plain)
2007-10-26 16:23 EDT, Charles R. Anderson
no flags Details

  None (edit)
Description Charles R. Anderson 2007-10-13 16:10:48 EDT
Description of problem:

rawhide-20071011-i686-Live liveinst fails with Anaconda errors reading /dev/sg2,
/dev/sg3, /dev/sg4, /dev/sg5, etc. and then tracebacks.

Version-Release number of selected component (if applicable):
11.3.0.38-1

How reproducible:
didn't try

Steps to Reproduce:
1. Boot rawhide LiveCD
2. Select "Install to Hard Drive"
3. Select keyboard type
4. Click "Cancel" on sg error dialog.
  
Actual results:

Error opening /dev/sg3: Invalid argument
Retry   Cancel

... traceback ...

Expected results:
No traceback.  Unsupported devices should be skipped perhaps.

Additional info:
This is a Dell PowerEdge 2650 server.
Comment 1 Charles R. Anderson 2007-10-13 16:11:52 EDT
Created attachment 226481 [details]
Anaconda traceback
Comment 2 Charles R. Anderson 2007-10-13 16:13:37 EDT
Created attachment 226491 [details]
.xsession-errors from LiveCD fedora user

Anaconda-related xsession-errors:

FATAL: Module md not found.
Probing for video card:   ATI Technologies Inc Rage XL
Starting graphical installation...
Loading /lib/kbd/keymaps/i386/qwerty/us.map.gz
Comment 3 Charles R. Anderson 2007-10-13 16:15:20 EDT
Created attachment 226511 [details]
Dell PowerEdge 2650 scsi info, dmesg, lspci, sg device info
Comment 4 Charles R. Anderson 2007-10-20 17:53:32 EDT
Same problem with 20071019 i686 live CD.  I worked around it by doing "rmmod sg"
before starting liveinst.
Comment 5 Jeremy Katz 2007-10-22 16:11:47 EDT
What's the output of 'kudzu -p -c HD' on this box?
Comment 6 Matt Domsch 2007-10-24 21:08:50 EDT
It appears that the kernel is now exposing the logical disk as /dev/sda (which
is correct), but is now also exposing the underlying physical disks as /dev/sg*
as well.  This would be fairly new behavior.  It's true - for doing useful
things like firmware upgrades on the drives, having a /dev/sg node for each is
good.  But anaconda isn't ready for that...
Comment 7 Matt Domsch 2007-10-25 14:11:58 EDT
From upstream:

commit e37ee4bec6c6d6d67aebafeecbbb32aa33d502bc
Author: Mark Haverkamp <markh@linux-foundation.org>
Date:   Fri Jan 26 09:23:32 2007 -0800

    [SCSI] aacraid: expanded expose physical device code (new)

    Received from Mark Salyzyn,

    Take the expose_physicals flag and allow the user to select default (physicals
    available via /dev/sg), exposed (physicals available via /dev/sd for
    experimental reasons) and hidden (physicals blocked from all access). This
    expands the functionality of the previous expose_physicals insmod parameter
    which was added to support some experimental configurations.

    Signed-off-by Mark Haverkamp <markh@linux-foundation.org>
    Signed-off-by: James Bottomley <James.Bottomley@SteelEye.com>
Comment 8 Matt Domsch 2007-10-25 14:15:04 EDT
so it's a module parameter 'expose_physicals', defaulting to value -1 meaning to
expose the disks as /dev/sg*.  This can be disabled by passing the module option
'expose_physicals=0'.  Or you can fix kudzu.

int expose_physicals = -1;
module_param(expose_physicals, int, S_IRUGO|S_IWUSR);
MODULE_PARM_DESC(expose_physicals, "Expose physical components of the arrays.
-1=protect 0=off, 1=on");

Comment 9 Jeremy Katz 2007-10-25 14:32:43 EDT
Or we can just filter them in anaconda.  Which is the route that's probably the
least risky and least likely to cause other problems.

Done.
Comment 10 Charles R. Anderson 2007-10-26 16:23:56 EDT
Created attachment 239551 [details]
output from 'kudzu -p -c HD'

Sorry for the delay, I was away.  Here is the kudzu output you requested.
Comment 11 Charles R. Anderson 2007-10-27 15:47:58 EDT
A regular anaconda install on this system worked fine today.  I haven't tried a
Live install, since there isn't a new LiveCD to test.  However, I think this bug
should be removed from blocking the release, since the regular install worked
fine and there is a good workaround for liveinst.  Besides, it sounds like you
fixed the bug already from discussion on fedora-test-list.  So, I'll go ahead
and close this.

Comment 12 Jeremy Katz 2007-10-28 13:57:42 EDT
*** Bug 351221 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.