Bug 33095 - CirrusLogic GD5446 PCI video corruption
CirrusLogic GD5446 PCI video corruption
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 39712 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 15:05 EST by David Lawrence
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-06 15:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Conifg-4 file (1.30 KB, text/plain)
2001-03-28 09:26 EST, Michael Young
no flags Details
XFree86.0.log file (16.82 KB, text/plain)
2001-03-28 09:27 EST, Michael Young
no flags Details
A window after being dragged around the screen (3.42 KB, image/gif)
2001-03-28 11:12 EST, Michael Young
no flags Details

  None (edit)
Description David Lawrence 2001-03-24 15:05:33 EST
using latest XFree86-4.0.3-3 and XFree86-SVGA-3.3.6-35, different levels of
video 
corruption is observed. When using 4.0.3 it is usable but the pointer
leaves square areas
of video garbage in some places. When using the 3.3.6 server, large bblocky
areas of video
corruption is all over the screen make it quite unusable.

1024x768x16
Comment 1 Mike A. Harris 2001-03-26 03:24:51 EST
Hmmm.  I haven't reproduced this yet, but just as a hunch, I'm guessing it
is either a hardware failure, or a compiler bug.  I could be abusing glue
here, but just a hunch.  I'll try it out and see what I can find though.

Is this a 1Mb card or a 2Mb one?
Comment 2 Preston Brown 2001-03-26 17:08:06 EST
wait mike, there is an old XFree86 report for the same series (GD54xx or 
something?) so I doubt it is compiler bug.
Comment 3 Mike A. Harris 2001-03-26 17:22:00 EST
Ok.  If it is a driver bug though it must be hardware related perhaps a
different vendor's board or differnt memory or something because I have
a 5446 here that I've used for 3 years until recently which never showed
this problem.  Perhaps it only manifests with some specific configuration?

To the original poster, can you provide me with your XF86Config-4 file and
a copy of your server logs?  I'll compare them with mine and see if anything
is different.  Attach them to the bug report using the link below.

Also, are you using KDE or GNOME, and what window manager are you using - just
so I can try to reproduce your environment as closely as possible.  I'm going
to check bugzilla for old reports that might be related.
Comment 4 Mike A. Harris 2001-03-28 06:43:53 EST
This is similar to bug #25939
Comment 5 Michael Young 2001-03-28 08:19:47 EST
I had this problem when I changed from 6.2 to Fisher. It went away in the
wolverine version (4.0.2-9) and the subsequent upgrades I tried, but the problem
has reappeared in 4.0.3-1 and 4.0.3-3. I will attempt to attach my copies of the
XF86Config-4 and XFree86.0.log from the latest run.
Comment 6 Mike A. Harris 2001-03-28 09:00:00 EST
Ok, can someone please try to make a screenshot of this corruption
for me?  Screenshooter does a great job of this.
Comment 7 Michael Young 2001-03-28 09:26:58 EST
Created attachment 13944 [details]
XF86Conifg-4 file
Comment 8 Michael Young 2001-03-28 09:27:42 EST
Created attachment 13945 [details]
XFree86.0.log file
Comment 9 Michael Young 2001-03-28 11:12:29 EST
Created attachment 13963 [details]
A window after being dragged around the screen
Comment 10 Michael Young 2001-03-28 11:15:01 EST
The attachment I have just added is a window after it has been dragged around
the screen - it looks better while actually being dragged.
Comment 11 Michael Young 2001-04-20 06:08:23 EDT
The problem has gone away in a clean install of Redhat 7.1, presumably because
the noaccel option that has appeared in XF86Config-4.
Comment 12 Mike A. Harris 2001-05-09 08:27:04 EDT
*** Bug 39712 has been marked as a duplicate of this bug. ***
Comment 13 Mike A. Harris 2001-05-09 08:31:03 EDT
Changing to Red Hat Linux 7.1 because people apparently still experience this
problem.  Added duplicate bug reporter to CC list.
Comment 14 Need Real Name 2001-05-14 02:44:14 EDT
I have an Intel L440GX+ with a cirrus Logic GD5480 2meg
I have experienced what seems to be faulty refreshing of the screen under 7.1 
(seawolf)with the new boot disk that came out today (this problem does not 
relate to it) and the xfs workaround to boot on my particular board.
After reading through some of the other tickets and this one, I went in and 
edited the XF86config file and added =Option "noaccel".
Works like a charm now. IMHO the Xconfigfurator is not putting this option in  
the XF86config file.
Hope this helps.
Comment 15 Need Real Name 2001-05-22 11:19:48 EDT
I have a Cirrus Logic GD5480 graphics card and I was getting all sorts of 
rendering errors X (as described above). I made the following modifications 
to /etc/X11/XF86Config generated by Xconfigurator:

where it says:
Section "Device"
   Identifier    "Cirrus Logic GD5480"
   Vendor Name   "Unknown"
   Board Name    "Unknown"
   #VideoRam     "2048"

I added another line:
   Option        "no_bitblt"

...and it appears fixed. I don't know enough about X configuration to know if 
this is better or worse than "noaccel" (suggested by  hologram007@hotmail.com), 
but the fact that "no_bitblt" works as well might help in the debugging 
detective work!
Comment 16 Michael Young 2001-05-23 05:36:00 EDT
I tried 'Option "no_bitblt"' instead of 'Option "Noaccel"' on my GD5446, and the
rendering problem is back. The X logs include the line
(WW) CIRRUS(0): Option "no_bitblt" is not used
Comment 17 R.K.Aa. 2001-05-30 07:30:51 EDT
This bug may be old as sin, and is most likely an XFree86 bug. Possibly related
to the v4l stuff.

AFAIK there were always some drawing oddities with the 5446 chipset's
direct-draw feature: I used to have this problem way back when Windows95 was
new, when running the old Hauppauge WinTV PCI card-drivers for Windows. Fonts in
all applications got seriously distorted. After half a year Hauppauge fixed it
in the Win-driver. I ported to Linux in 1999 and the exact same problem hit me
under RH Linux 6.0 using the bttv driver etc. Visible both under KDE and Gnome.
I used a GC5446 PCI 2MB at the time.
Comment 18 HSA_NOC_Engineer 2001-06-12 19:46:34 EDT
I am getting the same display anomalies with an Intel C440GX+ server board 
running the CL-GD5480 chip with 2megs of Vram. 

After all the trouble with bug 29555, and finally getting it to install, I find 
that I spent a whole lot of time on a system that I can now only use in Command 
Line.


This is ridiculous Redhat.  There are ALOT of these boards in the field . Shame 
on you for not better supporting this problem.


I have tried the Option "noaccell" as well as the Option "no_bitblt" and 
neither of these have solved my display artifact/distortion problem.  I did not 
have this problem with RH70 or 6.1. 

What gives. 



Thanks, and as always a loyal RedHat Linux supporter.  (albeit frustrated)


Brad Davenport
sublime-1@home.com
Comment 19 Ben Spencer 2001-06-12 19:53:56 EDT
I tried submitting this a while ago, but my bug was marked as a duplicate
or something.  I was able to fix the problem by adding the "hwcursor" option to
my XF86Config-4 file.  It works almost perfectly now.  Occasionally I see some 
corruption around the borders of things I select in KDE, but it's way better 
than it was.  I hope that helps someone else who is having similar problems.
Comment 20 ecook 2001-08-06 15:03:58 EDT
I also have the same problem with the GD5480 when I went from RH6.1 to RH7.1.  
I followed the previous posted suggestions and it solved my problem.

where it says in /etc/X11/XF86Config

Section "Device"
   Identifier    "Cirrus Logic GD5480"
   VideoRam     "2048"

I added another line:
   Option        "no_bitblt"


Not to sure why this works, but I'll live with it.
Comment 21 Mike A. Harris 2001-08-08 11:11:01 EDT
Problem finally fixed in rawhide XFree86 4.1.0-0.9.11

Note You need to log in before you can comment on or make changes to this bug.