Bug 33113 - rpm 4.0.2 breaks ucd-snmp (error in loading shared library)
rpm 4.0.2 breaks ucd-snmp (error in loading shared library)
Status: CLOSED DUPLICATE of bug 33085
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-25 05:18 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-25 05:18:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-25 05:18:24 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)


After installing RPM 4.0.2 ucd-snmp deamon won't start.

Reproducible: Always
Steps to Reproduce:
1. Install RPM 4.0.2 and DB3 RPM's on RedHat 6.2
2. Try to start snmpd: /etc/rc.d/init.d/snmpd start

Actual Results:  Snmpd fails with:
Starting snmpd: /usr/sbin/snmpd: error in loading shared 
libraries: /usr/lib/librpm.so.0: undefined symbol: fdio [FAILED]

Expected Results:  The deamon should be running.

All RPM are standard RedHat 6.2 ones. All previous updates are installed.
Comment 1 Jeff Johnson 2001-03-26 08:31:39 EST

*** This bug has been marked as a duplicate of 33085 ***
Comment 2 R.K.Aa. 2001-03-26 08:33:17 EST
it also breaks gnorpm 0.95 - same error:
error in loading shared libraries: /usr/lib/librpm.so.0: undefined symbol: fdio
I think priority on this bug should be raised a few notches. Very many RH users
rely on gnorpm.
Comment 3 Jeff Johnson 2001-03-26 08:40:22 EST
There will be an errata release for gnorpm shortly. Meanwhile, if you need a fix
today, recompile gnorpm from the src.rpm.

Note You need to log in before you can comment on or make changes to this bug.