Bug 33085 - all programs depending on using /usr/lib/librpm.so.0 crash
all programs depending on using /usr/lib/librpm.so.0 crash
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
: 32575 32584 33113 33272 33275 33353 33595 33681 33828 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-24 09:06 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 12:20:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-24 09:06:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)


All programs, ie up2date, helix-gnome updater, gnorpm fail with the
following error "error in loading shared librarys undefined symbol fdio"

Reproducible: Always
Steps to Reproduce:
1.Insalled new db3 programs on updated 6.2 system (current)
2.Install rpm 4.0.2-6x
3. did a rpm --rebuilddb . Then checked /var/lib/rpm to make sure
files are laid out as expected 
Try running gnorpm, or helix update 

	

Actual Results:  segfault on x based programs
error on shared libraries in command line
Comment 1 Andrew Ferguson 2001-03-24 15:47:30 EST
I am also having problems with the rpm-4.0.2-6x upgrade for RedHat 6.2 (I have
db3 installed). When I try to do `rpm --rebuilddb` (as specified in the
redhat-watch mail about this update), I get the following error:

rpmdb: header.c:511: headerLoad: Assertion `rdlen == dl' failed.
Aborted (core dumped)

A backtrace on the core produces:
#0  0x40172d21 in __kill () from /lib/libc.so.6
#1  0x40172996 in raise (sig=6) at ../sysdeps/posix/raise.c:27
#2  0x401740b8 in abort () at ../sysdeps/generic/abort.c:88
#3  0x4016cbae in __assert_fail () at assert.c:59
#4  0x4005941d in headerLoad () from /usr/lib/librpm.so.0
#5  0x40059fe9 in headerRead () from /usr/lib/librpm.so.0
#6  0x40081830 in doGetRecord () from /usr/lib/librpm.so.0
#7  0x40081b37 in db1cget () from /usr/lib/librpm.so.0
#8  0x4006a663 in dbiGet () from /usr/lib/librpm.so.0
#9  0x4006ca59 in XrpmdbNextIterator () from /usr/lib/librpm.so.0
#10 0x4006f52d in rpmdbRebuild () from /usr/lib/librpm.so.0
#11 0x804a2f0 in poptResetContext ()
#12 0x4016c9cb in __libc_start_main (main=0x8049c84 <poptResetContext+2712>, 
    argc=2, argv=0xbffffbdc, init=0x8048ecc <_init>, fini=0x804a3bc <_fini>, 
    rtld_fini=0x4000aea0 <_dl_fini>, stack_end=0xbffffbd4)
    at ../sysdeps/generic/libc-start.c:92

I have the following versions installed:
rpm-4.0.2-6x
db3-3.1.17-4.6x

This bug is a real pain as even a simple `rpm -qa` dies with the above error.
Thanks.
Comment 2 Jeff Johnson 2001-03-25 10:52:21 EST
The segfault is being caused by data in your database.

Try "rpm --rebuilddb -vv" and try removing the last package displayed.
Comment 3 Need Real Name 2001-03-25 15:23:35 EST
Well that last comment took care of the rpm problem for me. But did not take 
care of any depencency's on the librarys. Like gnomerpm while i know redhat is 
not responsible for the gnome rpm. They should at least compile all programs 
that will be affected by the library change. Or at least post what will be 
affected by them.
Comment 4 Andrew Ferguson 2001-03-25 18:10:57 EST
Thanks for the tip. Removing the last package didn't solve it, but by examaning
the database file I was able to discover the package afterwards and remove it by
downgrading my rpm, removing the package, rebuilding the database, upgrading to
rpm-4.0.2, rebuilding the database again, and reinstalling the package. The
problem was that I had the dev package installed twice in my database for some
reason (versions 2.7.7 and 2.7.18). Again, thanks for the tip. Everything works
fine now.
Comment 5 Need Real Name 2001-03-26 07:12:59 EST
I downloaded gnorpm-0.95.1-5.6x.i386.rpm installed it to make sure I was 
current. Still get the shared library error undefined symbol fdio I hope to
get the people over at helix-gnome on getting their system compatable with the 
new libraries too.
Comment 6 Jeff Johnson 2001-03-26 08:31:35 EST
*** Bug 33113 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Johnson 2001-03-26 08:32:33 EST
*** Bug 32584 has been marked as a duplicate of this bug. ***
Comment 8 Jeff Johnson 2001-03-26 14:52:45 EST
*** Bug 33275 has been marked as a duplicate of this bug. ***
Comment 9 Bill Nottingham 2001-03-27 01:03:06 EST
*** Bug 32575 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2001-03-27 01:04:03 EST
*** Bug 33272 has been marked as a duplicate of this bug. ***
Comment 11 Bill Nottingham 2001-03-27 01:05:01 EST
*** Bug 33353 has been marked as a duplicate of this bug. ***
Comment 12 Bill Nottingham 2001-03-28 12:20:52 EST
*** Bug 33595 has been marked as a duplicate of this bug. ***
Comment 13 Jeff Johnson 2001-03-28 13:31:21 EST
Errata for gnorpm/ucd-snmp to work with rpm-4.0.2 on Red Hat 6.x will be along
shortly.
Comment 14 Jeremy Katz 2001-03-28 16:34:15 EST
*** Bug 33681 has been marked as a duplicate of this bug. ***
Comment 15 Gilbert E. Detillieux 2001-03-28 18:07:49 EST
ucd-snmp-utils was not included in the updates (nor was the devel package),
but the previous utils don't work for the same reason as the daemon, i.e. due
to the change in librpm.so.

Will ucd-snmp-utils also be issued as an update RPM, or do we have to recompile
from the SRPM if we really need it?
Comment 16 Jeff Johnson 2001-03-29 09:28:55 EST
The errata for ucd-snmp has been repushed with the devel/utils packages as well.
Thanks for reporting.
Comment 17 Bill Nottingham 2001-03-29 10:58:05 EST
*** Bug 33828 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.