Bug 331261 - Live-CD install doesn't recognize other OS installs
Live-CD install doesn't recognize other OS installs
Status: CLOSED DUPLICATE of bug 322401
Product: Fedora
Classification: Fedora
Component: LiveCD (Show other bugs)
8
i686 Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-14 06:22 EDT by Jason Taylor
Modified: 2013-01-09 23:27 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-16 10:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Taylor 2007-10-14 06:22:04 EDT
Description of problem:

Fresh install from FC7 does not list or detect Vista install

Version-Release number of selected component (if applicable):

FC8test3

How reproducible:
Install from LiveCD with dual boot prexisting with multiple OS's

Steps to Reproduce:
1.LiveCD install
2. Bootloader install screen does not list other OS's on system
3.
  
Actual results:
No listing or detection of secondary OS

Expected results:
"Other" grub label has in the past always been listed and modified to whatever
Windows version I have been running. In LiveCD no such listing is present.

Additional info:
Comment 1 Jason Taylor 2007-10-14 06:34:56 EDT
I had been running FC7 and Vista with grub handling the booting. I installed
FC8test3 from LiveCD when setting up grub the only detect/shown OS was the new
FC8test3 with no "Other" as Windows partitions in the past have been labeled.
The partions are all identified during the install 40 GB for FC and 40 GB for
Windows.  Current fdisk listing shows

Disk /dev/sda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x40000000

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        5100    40960000    7  HPFS/NTFS
/dev/sda2            5101        5112       96390   83  Linux
/dev/sda3            5113        9729    37086052+  8e  Linux LVM

Disk /dev/dm-0: 35.8 GB, 35836133376 bytes
255 heads, 63 sectors/track, 4356 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000


Disk /dev/dm-1: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

current grub.conf

#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,1)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.23-6.fc8)
        root (hd0,1)
        kernel /vmlinuz-2.6.23-6.fc8 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.23-6.fc8.img
title Fedora (2.6.23-0.214.rc8.git2.fc8)
        root (hd0,1)
        kernel /vmlinuz-2.6.23-0.214.rc8.git2.fc8 ro
root=/dev/VolGroup00/LogVol00 rhgb quiet
        initrd /initrd-2.6.23-0.214.rc8.git2.fc8.img
title Vista
        rootnoverify (hd0,2)
        chainloader +1
Comment 2 Jason Taylor 2007-10-14 06:47:54 EDT
Ok, after the reboot and updates finished I just manually added the boot
information to grub but I am still curious why it didn't add it in the first
place? thanks and sorry for replying to myself

title Vista
        rootnoverify (hd0,0)
        chainloader +1
Comment 3 Jeremy Katz 2007-10-16 10:57:27 EDT

*** This bug has been marked as a duplicate of 322401 ***

Note You need to log in before you can comment on or make changes to this bug.