Bug 322401 - no grub option for windows
Summary: no grub option for windows
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 8
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 331261 344761 (view as bug list)
Depends On:
Blocks: F8Blocker
TreeView+ depends on / blocked
 
Reported: 2007-10-07 18:10 UTC by Riku Seppala
Modified: 2007-11-30 22:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 17:25:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (37.55 KB, application/octet-stream)
2007-10-07 18:10 UTC, Riku Seppala
no flags Details

Description Riku Seppala 2007-10-07 18:10:47 UTC
fedora 8 test 3 x86_64 on HP dv9000z series laptop with windows installed. After
installing fedora only option on grub is fedora. Same problem with test 2, sorry
for not bugzilling earlier. I have to manually edit grub.conf again. What info
you need for this? I'll attach the anaconda.log.

Comment 1 Riku Seppala 2007-10-07 18:10:47 UTC
Created attachment 218831 [details]
anaconda.log

Comment 2 Russell Harrison 2007-10-08 14:16:00 UTC
I also had to manually add the option to boot /dev/sda1 in the anaconda grub
setup screen.

Comment 3 sean 2007-10-08 17:02:05 UTC
Same for me, I think. 

Vista is on sda1, and the vista recovery partition is sda5. The grub boot
configuration screen ( text mode ) only shows sda4 Fedora, where f8t3 is to be
installed.

Unlike Comment 2, I can't see any way to add sda1.

Comment 4 Jeremy Katz 2007-10-09 15:48:33 UTC
If you run parted on /dev/sda, what does it say the filesystem type of sda1 is?

Comment 5 Riku Seppala 2007-10-09 16:17:37 UTC
(parted) print sda1
Model: ATA Hitachi HTS54161 (scsi)
Disk /dev/sda: 160GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End    Size    Type     File system  Flags
 1      32.3kB  107GB  107GB   primary  ntfs         boot
 2      107GB   107GB  107MB   primary  ext3
 3      107GB   160GB  52.8GB  primary               lvm


Comment 6 Jeremy Katz 2007-10-10 17:25:27 UTC
Okay, I see what's going on.  Fixed up in booty-0.89

Comment 7 Jeremy Katz 2007-10-16 14:57:28 UTC
*** Bug 331261 has been marked as a duplicate of this bug. ***

Comment 8 Jeremy Katz 2007-10-22 01:02:30 UTC
*** Bug 344761 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.