Bug 33168 - Installer crashes running Anaconda, even with update image
Installer crashes running Anaconda, even with update image
Status: CLOSED DUPLICATE of bug 18019
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-25 23:10 EST by Alvaro Medina
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-19 23:53:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alvaro Medina 2001-03-25 23:10:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001108
Netscape6/6.0


When installing Red Hat 7.0 the program crashes, while running Anaconda. I
had a similar problem, a known bug, and I downloaded the update image, and
used it. That bug disappeared, but then is this other.

Reproducible: Always
Steps to Reproduce:
1.Booted installer from floppy. In propmt, entered : "linux updates"
2.After selecting language, keyboard, etc. and installing media (cd-rom or
hard drive), the program asks for the update disk. I inserted the disk.
3. When reading the update image, the program crashes.
	

Actual Results:  Running Anaconda... etc.

Traceback (innermost last):
file "usr/bin/anaconda.real" , line 206, in ?
	from todo import ToDo
file "/tmp/updates/todo.py", line 27, in ?
	import fstab
file "/tmp/updates/fstab.py", line 427

	^

Syntax Error : invalid syntax.
install exited abnormally
Sending kill signal....

etc., the system goes down.

Expected Results:  I expected Red Hat would have been installed!

My machine is a P-II 400mhz, 8.1 GB primary hd - 540 MB secondary hd, 64 MB
RAM. The primary hard disk is partitioned in one Windows 95 fat, one Linux
native and one Linux swap partition, from a previous Linux install (no Red
Hat).
Comment 1 Michael Fulbright 2001-03-26 16:04:00 EST
It is very likely the floppy you used is corrupt. I would recommend downloading
the update again and trying a different floppy.
Comment 2 Alvaro Medina 2001-03-28 21:09:07 EST
Yes, it passed through, it was a corrupt disk. But now I am getting the same bug
I am trying to fix with the update! The error messages is as it follows:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in run
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/textw/packages_text.py", line
33, in __call__
  File "/tmp/updates/todo.py", line 539, in getCompsList
    self.comps = self.method.readComps(self.hdList)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/harddrive.py", line 43, in
readComps
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 459, in __init__
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 428, in
readCompsFile
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/comps.py", line 101, in
__getitem__
KeyError: perl

Local variables in innermost frame:
self: <comps.HeaderList instance at 8332210>
item: perl

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iharddrive
HardDriveInstallMethod
p4
(dp5
S'fstype'
p6
S'vfat'
p7
sS'isMounted'
p8
I1
sS'fnames'
p9
(dp10

<failed>


So, almost the exact bug. What can be going on?
Comment 3 Michael Fulbright 2001-04-02 12:11:02 EDT
This bug has occurred in my experience when something about the hard drive
install image is corrupt, in this case it looks like the perl RPM is corrupt or
missing. This can happen when downloaded the files.

I would recommend trying to use a different server and grabbing the perl RPM and
replacing your current one.
Comment 4 Brent Fox 2001-04-19 23:53:21 EDT

*** This bug has been marked as a duplicate of 18019 ***

Note You need to log in before you can comment on or make changes to this bug.