Bug 3318 - XF86Setup core dumps everytime you want to change your keyboard type with it
XF86Setup core dumps everytime you want to change your keyboard type with it
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
:
: 4732 5865 11293 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-07 13:23 EDT by kazadi
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-08 10:48:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description kazadi 1999-06-07 13:23:39 EDT
I am running RedHat 6.0 on an X86 platform configured as
such:

I686 Pentium II 400 Processor
Asus P2B Motherboard
128 Megs memory
Diamond Viper V550 Video card
Creative labs AWE64 PNP sound card
Two 4 GIG IBM SCSI HD's
One 9 GIG Seagate SCSI HD
On board 7890 SCSI controller.

With this configuration, every time I try to change my
keyboard type in the XF86Setup GUI it crashes the app ans
causes an application core dump.

Should you need me to send you a copy of the core, please
let me know and I will be happy to.

Thank you,
Kamran Azadi
Comment 1 Jay Turner 1999-06-07 13:45:59 EDT
Confirmed in test lab, switching from 101-key to 104-key keyboard.

Output of gdb is as follows:
Program received signal SIGSEGV, Segmentation fault.
0x402ed55c in chunk_free (ar_ptr=0x305, p=0x81d7748) at malloc.c:2960
malloc.c:2960: No such file or directory.
Comment 2 Preston Brown 1999-08-26 21:02:59 EDT
*** Bug 4732 has been marked as a duplicate of this bug. ***

->Run through an XF86Setup as follows:
GNOME Terminal
su
XF86Setup
Yes (reconfig)
Keyboard
Make Caps Lock an Additional Control
Apply
->at this point XF86Setup gets a Segmentation Fault
and dumps a core file. However, the requested change
does take effect.
Comment 3 Scott D. Webster 1999-09-14 18:46:59 EDT
I'm also getting a core dump from FX86Setup at the end when or before
it attempts to write a new XF86Config file.  Xconfigurator works fine,
however.
Comment 4 Preston Brown 2000-02-11 10:08:59 EST
*** Bug 5865 has been marked as a duplicate of this bug. ***
Comment 5 Preston Brown 2000-05-08 10:48:59 EDT
*** Bug 11293 has been marked as a duplicate of this bug. ***
Comment 6 Preston Brown 2000-06-26 15:18:20 EDT
we do not support XF86Setup, as we ship Xconfigurator instead.  XF86Setup will
be removed from the next version of Red Hat Linux.

Note You need to log in before you can comment on or make changes to this bug.