Bug 333721 - java-1.7.0-icedtea lacks sound support
java-1.7.0-icedtea lacks sound support
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-16 05:01 EDT by Bastien Nocera
Modified: 2007-12-25 01:30 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 15:43:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bastien Nocera 2007-10-16 05:01:58 EDT
java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
java-1.7.0-icedtea-plugin-1.7.0.0-0.16.b19.snapshot.fc8

The applet fails to start trying to play Duck Tales on virtualnes.com:
http://virtualnes.com/play/play.php?id=A963&s=6

Here's the startup logs:
GCJ PLUGIN: thread 0x740510: NP_Initialize
GCJ PLUGIN: thread 0x740510: plugin_test_appletviewer
GCJ PLUGIN: thread 0x740510: plugin_test_appletviewer return
GCJ PLUGIN: thread 0x740510: NP_Initialize: using
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/lib/amd64/../../bin/pluginappletviewer
GCJ PLUGIN: thread 0x740510: NP_Initialize return
GCJ PLUGIN: thread 0x740510: GCJ_New
GCJ PLUGIN: thread 0x740510: plugin_data_new
GCJ PLUGIN: thread 0x740510: plugin_data_new return
GCJ PLUGIN: thread 0x740510: plugin_get_documentbase
GCJ PLUGIN: thread 0x740510: plugin_get_documentbase return
GCJ PLUGIN: thread 0x740510: GCJ_New: creating input fifo:
/home/hadess/.gcjwebplugin/gcj-instance-30578-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x740510: GCJ_New: created input fifo:
/home/hadess/.gcjwebplugin/gcj-instance-30578-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x740510: GCJ_New: creating output fifo:
/home/hadess/.gcjwebplugin/gcj-instance-30578-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x740510: GCJ_New: created output fifo:
/home/hadess/.gcjwebplugin/gcj-instance-30578-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x740510: plugin_start_appletviewer
GCJ PLUGIN: thread 0x740510: plugin_start_appletviewer return
GCJ PLUGIN: thread 0x740510: GCJ_New: got confirmation that appletviewer is running.
GCJ PLUGIN: thread 0x740510: plugin_create_applet_tag
GCJ PLUGIN: thread 0x740510: plugin_create_applet_tag return
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-30578-0
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: tag http://virtualnes.com/play/play.php?id=A963&s=6 <EMBED
CODE="AppletGui.class" CODEBASE="http://vnes.salmonthievery.com/"
ARCHIVE="http://vnes.salmonthievery.com/i.jar" HEIGHT="480" WIDTH="512" ><PARAM
NAME="rom" VALUE="http://vnes.salmonthievery.com/g/A963"><PARAM NAME="romsize"
VALUE="131088"><PARAM NAME="scale" VALUE="on"><PARAM NAME="sound"
VALUE=""><PARAM NAME="nicesound" VALUE="on"><PARAM NAME="stereo" VALUE="on"></EMBED>
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: GCJ_New return
  PIPE: appletviewer wrote: running
  PIPE: appletviewer read: instance-30578-0
  PIPE: appletviewer read: tag http://virtualnes.com/play/play.php?id=A963&s=6
<EMBED CODE="AppletGui.class" CODEBASE="http://vnes.salmonthievery.com/"
ARCHIVE="http://vnes.salmonthievery.com/i.jar" HEIGHT="480" WIDTH="512" ><PARAM
NAME="rom" VALUE="http://vnes.salmonthievery.com/g/A963"><PARAM NAME="romsize"
VALUE="131088"><PARAM NAME="scale" VALUE="on"><PARAM NAME="sound"
VALUE=""><PARAM NAME="nicesound" VALUE="on"><PARAM NAME="stereo" VALUE="on"></EMBED>
GCJ PLUGIN: thread 0x740510: NP_GetValue
GCJ PLUGIN: thread 0x740510: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x740510: NP_GetValue return
GCJ PLUGIN: thread 0x740510: GCJ_GetValue
GCJ PLUGIN: thread 0x740510: GCJ_GetValue: returning TRUE for NeedsXEmbed.
GCJ PLUGIN: thread 0x740510: GCJ_GetValue return
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: setting window.
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-30578-0
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: handle 65018553
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow return
  PIPE: appletviewer read: instance-30578-0
  PIPE: appletviewer read: handle 65018553GCJ PLUGIN: thread 0x740510: GCJ_SetWindow
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: window width changed.
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-30578-0
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: width 512
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: window height changed.
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-30578-0
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: height 480
GCJ PLUGIN: thread 0x740510: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow return

GCJ PLUGIN: thread 0x740510: GCJ_SetWindow
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow return
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x740510: GCJ_SetWindow return
Warning: <param name=... value=...> tag requires name attribute.
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback: setting status starting
applet...
  PIPE: plugin read: status starting applet...
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status starting applet...
  PIPE: appletviewer read: instance-30578-0
  PIPE: appletviewer read: width 512
  PIPE: appletviewer read: instance-30578-0
  PIPE: appletviewer read: height 480
  PIPE: appletviewer wrote: status Applet loaded.
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback: setting status Applet loaded.
  PIPE: plugin read: status Applet loaded.
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status exception: java.lang.RuntimeException: Not
implemented..GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback: setting status exception:
java.lang.RuntimeException: Not implemented..
  PIPE: plugin read: status exception: java.lang.RuntimeException: Not implemented..
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback return

java.lang.RuntimeException: Not implemented.
        at com.sun.media.sound.JDK13Services.getProviders(JDK13Services.java:57)
        at javax.sound.sampled.AudioSystem.getProviders(AudioSystem.java:1630)
        at javax.sound.sampled.AudioSystem.getMixerProviders(AudioSystem.java:1377)
        at javax.sound.sampled.AudioSystem.getMixerInfoList(AudioSystem.java:1596)
        at javax.sound.sampled.AudioSystem.getMixerInfo(AudioSystem.java:198)
        at PAPU.start(PAPU.java:177)
        at NES.enableSound(NES.java:390)
        at NES.<init>(NES.java:75)
        at AppletUI.<init>(AppletUI.java:19)
        at AppletGui.init(AppletGui.java:31)
        at sun.applet.AppletPanel.run(AppletPanel.java:436)
        at java.lang.Thread.run(Thread.java:659)
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback: setting status Start:
applet not initialized.
  PIPE: plugin read: status Start: applet not initialized.
GCJ PLUGIN: thread 0x740510: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status Start: applet not initialized.
Comment 1 Michal Jaegermann 2007-10-24 16:57:28 EDT
Here is more applets which end up with "Start: applet not initialized".
Those on the following pages:
http://www.colorado.edu/physics/2000/xray/making_xrays.html
http://www.colorado.edu/physics/2000/tomography/x_rays.html
http://www.colorado.edu/physics/2000/tomography/final_rib_cage.html
http://www.colorado.edu/physics/2000/tomography/auto_rig_cage.html

Various applets from http://www.colorado.edu/physics/2000/ do work
although I do not know if the list above cannot be extended if one
would try all of them (and a pretty extensive collection is available
at that location).  With java plugin from Sun all the above are fine.

This was checked with
java-1.7.0-icedtea-plugin-1.7.0.0-0.19.b21.snapshot.fc8.x86_64
Comment 2 Michal Jaegermann 2007-10-24 16:59:37 EDT
Oops!  Read http://www.colorado.edu/physics/2000/tomography/auto_rib_cage.html
instead of "auto_rig..."
Comment 3 Thomas Fitzsimmons 2007-10-24 17:19:24 EDT
I've generalized the summary for reference purposes.  IcedTea currently lacks
sound support.

I'll clone this report to deal with Michal's unrelated issues.
Comment 4 Joshua Sumali 2007-11-02 15:15:17 EDT
(In reply to comment #0)
> java-1.7.0-icedtea-1.7.0.0-0.16.b19.snapshot.fc8
> java-1.7.0-icedtea-plugin-1.7.0.0-0.16.b19.snapshot.fc8
> 
> The applet fails to start trying to play Duck Tales on virtualnes.com:
> http://virtualnes.com/play/play.php?id=A963&s=6

Some sound sources have been open since b20 of openjdk, so sound (non-MIDI) is
mostly working with the most current IcedTea.

Unfortunately, that applet still does not work, but that may be due to another
(possibly unrelated) issue. Sound does work on other applets I have tested, though.
Comment 5 Lillian Angel 2007-11-15 15:43:54 EST
Sound support has been added to IcedTea. The new version of IcedTea is being
built into Rawhide at the moment.

I created this bug report because the applet
(http://virtualnes.com/play/play.php?id=A963&s=6) still does not work:
https://bugzilla.redhat.com/show_bug.cgi?id=385531

Note You need to log in before you can comment on or make changes to this bug.