Bug 385531 - virtualnes applet does not load
virtualnes applet does not load
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-11-15 15:39 EST by Lillian Angel
Modified: 2008-05-13 11:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 09:31:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lillian Angel 2007-11-15 15:39:46 EST
http://virtualnes.com/play/play.php?id=A963&s=6 

This applet doesn't work. Browser debug info does not show any errors.

The applet loads, but flashes or locks up the browser




GCJ PLUGIN: thread 0x8ed1488: NP_Initialize
GCJ PLUGIN: thread 0x8ed1488: plugin_test_appletviewer
GCJ PLUGIN: thread 0x8ed1488: plugin_test_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: NP_Initialize: using
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/lib/i386/../../bin/pluginappletviewer
GCJ PLUGIN: thread 0x8ed1488: NP_Initialize return
GCJ PLUGIN: thread 0x8ed1488: GCJ_New
GCJ PLUGIN: thread 0x8ed1488: plugin_data_new
GCJ PLUGIN: thread 0x8ed1488: plugin_data_new return
GCJ PLUGIN: thread 0x8ed1488: plugin_get_documentbase
GCJ PLUGIN: thread 0x8ed1488: plugin_get_documentbase return
GCJ PLUGIN: thread 0x8ed1488: GCJ_New: creating input fifo:
/home/langel/.gcjwebplugin/gcj-instance-12142-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x8ed1488: GCJ_New: created input fifo:
/home/langel/.gcjwebplugin/gcj-instance-12142-0-appletviewer-to-plugin
GCJ PLUGIN: thread 0x8ed1488: GCJ_New: creating output fifo:
/home/langel/.gcjwebplugin/gcj-instance-12142-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x8ed1488: GCJ_New: created output fifo:
/home/langel/.gcjwebplugin/gcj-instance-12142-0-plugin-to-appletviewer
GCJ PLUGIN: thread 0x8ed1488: plugin_start_appletviewer
GCJ PLUGIN: thread 0x8ed1488: plugin_start_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: GCJ_New: got confirmation that appletviewer is
running.
GCJ PLUGIN: thread 0x8ed1488: plugin_create_applet_tag
GCJ PLUGIN: thread 0x8ed1488: plugin_create_applet_tag return
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: tag http://virtualnes.com/play/play.php?id=A963&s=6 <EMBED
CODE="AppletGui.class" CODEBASE="http://www.atomicconcepts.net/"
ARCHIVE="http://www.atomicconcepts.net/i.jar" HEIGHT="480" WIDTH="512" ><PARAM
NAME="rom" VALUE="http://www.atomicconcepts.net/g/A963"><PARAM NAME="romsize"
VALUE="131088"><PARAM NAME="scale" VALUE="on"><PARAM NAME="sound"
VALUE=""><PARAM NAME="nicesound" VALUE="on"><PARAM NAME="stereo" VALUE="on"></EMBED>
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: GCJ_New return
  PIPE: appletviewer wrote: running
  PIPE: appletviewer read: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: NP_GetValue
GCJ PLUGIN: thread 0x8ed1488: NP_GetValue: returning plugin description.
GCJ PLUGIN: thread 0x8ed1488: NP_GetValue return
GCJ PLUGIN: thread 0x8ed1488: GCJ_GetValue
GCJ PLUGIN: thread 0x8ed1488: GCJ_GetValue: returning TRUE for NeedsXEmbed.
GCJ PLUGIN: thread 0x8ed1488: GCJ_GetValue return
  PIPE: appletviewer read: tag http://virtualnes.com/play/play.php?id=A963&s=6
<EMBED CODE="AppletGui.class" CODEBASE="http://www.atomicconcepts.net/"
ARCHIVE="http://www.atomicconcepts.net/i.jar" HEIGHT="480" WIDTH="512" ><PARAM
NAME="rom" VALUE="http://www.atomicconcepts.net/g/A963"><PARAM NAME="romsize"
VALUE="131088"><PARAM NAME="scale" VALUE="on"><PARAM NAME="sound"
VALUE=""><PARAM NAME="nicesound" VALUE="on"><PARAM NAME="stereo" VALUE="on"></EMBED>
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: setting window.
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: handle 44041720
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow return
  PIPE: appletviewer read: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: window width changed.
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: width 512
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: window height changed.
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: instance-12142-0
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer
  PIPE: plugin wrote: height 480
GCJ PLUGIN: thread 0x8ed1488: plugin_send_message_to_appletviewer return
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow return
  PIPE: appletviewer read: handle 44041720
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow return
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow: window already exists.
GCJ PLUGIN: thread 0x8ed1488: GCJ_SetWindow return
Warning: <param name=... value=...> tag requires name attribute.
  PIPE: appletviewer wrote: status starting applet...GCJ PLUGIN: thread
0x8ed1488: plugin_in_pipe_callback

GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback: setting status starting
applet...
  PIPE: plugin read: status starting applet...
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback return
  PIPE: appletviewer read: instance-12142-0
  PIPE: appletviewer read: width 512
  PIPE: appletviewer read: instance-12142-0
  PIPE: appletviewer read: height 480
  PIPE: appletviewer wrote: status Applet loaded.GCJ PLUGIN: thread 0x8ed1488:
plugin_in_pipe_callback
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback: setting status Applet loaded.

  PIPE: plugin read: status Applet loaded.
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status Applet initialized.GCJ PLUGIN: thread
0x8ed1488: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback: setting status Applet
initialized.
  PIPE: plugin read: status Applet initialized.
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback return

GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback: setting status Applet
started.
  PIPE: plugin read: status Applet started.
GCJ PLUGIN: thread 0x8ed1488: plugin_in_pipe_callback return
  PIPE: appletviewer wrote: status Applet started.
vNES 2.01 (C) 2007 Jamie Sanders
Comment 1 adhisimon 2007-11-22 11:01:24 EST
I confirm this bug. Although Firefox is success verifying java installation on
http://www.java.com. 

Firefox also succesfully start applets at:
 * Text Twist on Yahoo Games

But it can not start applets at some sites such as:
 * http://www.netdania.com/
 * http://www.forexhsi.com/

Firefox's status bar show:
 * starting applet
 * Start: applet not initialized

Comment 2 Lillian Angel 2007-11-22 11:33:51 EST
This applet works for me: http://www.forexhsi.com/
This one uses javascript: http://www.netdania.com/ - see bug #304021

Comment 3 Thomas Fitzsimmons 2007-11-23 16:50:28 EST
The vnes applet attempts to open the audio source data line twice.  The second
attempt triggers this exception from IcedTea's sound implementation:

javax.sound.sampled.LineUnavailableException: line with format PCM_SIGNED
44100.0 Hz, 16 bit, stereo, 4 bytes/frame, little-endian not supported.
        at
com.sun.media.sound.DirectAudioDevice$DirectDL.implOpen(DirectAudioDevice.java:511)
        at com.sun.media.sound.AbstractDataLine.open(AbstractDataLine.java:124)
        at com.sun.media.sound.AbstractDataLine.open(AbstractDataLine.java:156)
        at PAPU.start(PAPU.java:198)
        at NES.enableSound(NES.java:390)
        at AppletGui.init(AppletGui.java:39)
        at sun.applet.AppletPanel.run(AppletPanel.java:435)
        at java.lang.Thread.run(Thread.java:674)

The sound implementation in Sun's 1.6 JDK is able to open multiple source data
lines but IcedTea's is not.

vnes works with sound on IcedTea's appletviewer if I remove the line:

enableSound(true);

from NES.java then recompile.
Comment 4 Thomas Fitzsimmons 2007-11-23 19:25:23 EST
Reported upstream:

http://mail.openjdk.java.net/pipermail/sound-dev/2007-November/000045.html
Comment 5 Mark Wielaard 2008-05-05 05:31:04 EDT
Workaround added to icedtea repo:
http://mail.openjdk.java.net/pipermail/distro-pkg-dev/2008-May/001873.html
Comment 6 Lillian Angel 2008-05-05 16:31:29 EDT
will be in the next release.
Comment 7 Fedora Update System 2008-05-06 09:31:03 EDT
java-1.6.0-openjdk-1.6.0.0-0.12.b09.fc9 has been submitted as an update for Fedora 9
Comment 8 Fedora Update System 2008-05-13 11:25:42 EDT
java-1.6.0-openjdk-1.6.0.0-0.12.b09.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.