This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 333831 - /net does not seem to work with 5.0.1-19 or 5.0.2-6
/net does not seem to work with 5.0.1-19 or 5.0.2-6
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: autofs (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ian Kent
Brock Organ
:
Depends On: 248943
Blocks: 426500
  Show dependency treegraph
 
Reported: 2007-10-16 06:03 EDT by Ian Kent
Modified: 2008-05-21 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2008-0354
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 10:38:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch to fix handle trailing slash in quoted entry from hosts map (445 bytes, patch)
2007-10-16 06:03 EDT, Ian Kent
no flags Details | Diff

  None (edit)
Description Ian Kent 2007-10-16 06:03:29 EDT
+++ This bug was initially created as a clone of Bug #248943 +++

I have a Fedora 7 system installed and am trying to run the 2.6.22.1-23
kernel from FC-6.  I discovered that automount seems to loop constantly.
This would seem to be bz247711.  The solution posted there was to try
the autofs-5.0.1-19 rpm.

In my research and trying to resolve the problem, I tried the 5.0.1-19
and 5.0.2-6 rpms.  I think that they resolve the automount looping
issue, but then I discovered that /net no longer worked.

To reproduce this, install F-7 with the latest released kernel and then
upgrade autofs to either 5.0.1-19 or 5.0.2-6 and then try to access an
known good NFS server.

I got ENOENT when trying to do this.  I used tethereal to watch the
traffic between the client and the server and I could see the MOUNT
EXPORT call being made and responded to, but then nothing got mounted
on the client.

-- Additional comment from ikent@redhat.com on 2007-07-19 23:29 EST --
(In reply to comment #0)
> I have a Fedora 7 system installed and am trying to run the 2.6.22.1-23
> kernel from FC-6.  I discovered that automount seems to loop constantly.
> This would seem to be bz247711.  The solution posted there was to try
> the autofs-5.0.1-19 rpm.
> 
> In my research and trying to resolve the problem, I tried the 5.0.1-19
> and 5.0.2-6 rpms.  I think that they resolve the automount looping
> issue, but then I discovered that /net no longer worked.
> 
> To reproduce this, install F-7 with the latest released kernel and then
> upgrade autofs to either 5.0.1-19 or 5.0.2-6 and then try to access an
> known good NFS server.
> 
> I got ENOENT when trying to do this.  I used tethereal to watch the
> traffic between the client and the server and I could see the MOUNT
> EXPORT call being made and responded to, but then nothing got mounted
> on the client.

OK, appears to be OK with 2.6.21-1.3228.fc7.
I'll grab a 2.6.22 kernel and see if I can duplicate
the problem.

Ian


-- Additional comment from masaki-c@nict.go.jp on 2007-07-20 02:47 EST --
May be a nfs server problem?
I have a similar but strange problem.

My problem is this.
A nfs server exports some directories, but automount can found only 
a part of it when parseing /net/(something)

The server which has the probrem is CentOS4.5.
Fedora7 server seems to work fine.

Of course, it works fine when mounting by hand the server Centos4.5.

-- Additional comment from masaki-c@nict.go.jp on 2007-07-20 04:27 EST --
I found that it is the nfs server problem in my case.
'showmount -e' reportED different result between CentOS4.5 and F7.

While I was editing /etc/exports and re-exporting to find the condition 
of the probelm happens, suddenly 'swhomount -e' reports correctly and
I can't reproduce the problem anymore.

-- Additional comment from staubach@redhat.com on 2007-07-20 07:50 EST --
This is not a server problem for me.  The data going over the wire in
the MOUNT EXPORT call is fine and the server works fine for other clients.

-- Additional comment from staubach@redhat.com on 2007-07-20 08:55 EST --
I've now tested autofs-5.0.1-18 with kernel-2.6.21-1.3228.fc7 and /net
does not work there either.  These are the latest rpms available for
a F-7 i686 system.

-- Additional comment from ikent@redhat.com on 2007-07-20 09:01 EST --
(In reply to comment #5)
> I've now tested autofs-5.0.1-18 with kernel-2.6.21-1.3228.fc7 and /net
> does not work there either.  These are the latest rpms available for
> a F-7 i686 system.

I have two F7 systems here both have been using
kernel-2.6.21-1.3228.fc7 for some time.

I haven't been able to reproduce this so far.
I'll re-check everything and try again.

Ian


-- Additional comment from staubach@redhat.com on 2007-07-20 09:06 EST --
I don't know what to say.  autofs-5.0.1-18 just became available
this morning via "yum update" in Westford.  I let yum update the
rpm and then rebooted.  After reboot, I couldn't access a known
good, working server via /net.

-- Additional comment from ikent@redhat.com on 2007-07-20 09:23 EST --
(In reply to comment #7)
> I don't know what to say.  autofs-5.0.1-18 just became available
> this morning via "yum update" in Westford.  I let yum update the
> rpm and then rebooted.  After reboot, I couldn't access a known
> good, working server via /net.

Yep .. it is strange.

I downloaded revision 18 from a mirror instead of building
locally and I'm still not able to see the problem on either
my x86_64 or i396 systems.

How about posting the output of "showmount -e" and I'll setup
my NFS server to be similar.

Ian



-- Additional comment from staubach@redhat.com on 2007-07-20 09:32 EST --
The server in question has two exported file systems, / and /usr/src.

The output from "showmount -e" looks like:

    Export list for nyday:
    /        *
    /usr/src *

Just for grins, these file systems are exported via:

    /               *(ro,sync,fsid=0)
    /usr/src        *(rw,sync,nohide,no_root_squash)

Which makes them available for all versions of NFS.

-- Additional comment from ikent@redhat.com on 2007-07-20 09:41 EST --
(In reply to comment #9)
> The server in question has two exported file systems, / and /usr/src.
> 
> The output from "showmount -e" looks like:
> 
>     Export list for nyday:
>     /        *
>     /usr/src *
> 
> Just for grins, these file systems are exported via:
> 
>     /               *(ro,sync,fsid=0)
>     /usr/src        *(rw,sync,nohide,no_root_squash)
> 
> Which makes them available for all versions of NFS.

Ha .. duplicated the problem.
I'll keep working on it, sorry for the inconvenience.

Ian


-- Additional comment from ikent@redhat.com on 2007-07-20 10:47 EST --
Think I've found the problem.
I recently had a bug where autofs didn't handle spaces
in exports for the "-hosts" map. To solve it I just quoted
entries in the export and passed it on "knowing" the parser
would deal with the quoting. But I didn't count on getting
caught by a test which is supposed to remove a trailing "/"
from a path. It turned "/" into NULL after the quote removal.

Ian


-- Additional comment from ikent@redhat.com on 2007-07-20 10:50 EST --
Created an attachment (id=159658)
Patch to correct handling of quoted slash alone

fyi, this is the patch I think will fix this.
I'll commit this to F-7 and devel soon as I can.

Ian


-- Additional comment from staubach@redhat.com on 2007-07-20 10:58 EST --
Thanx for jumping on this so quickly, Ian.  It is much appreciated.

-- Additional comment from ikent@redhat.com on 2007-07-20 11:06 EST --
Ahh .. but wait, it looks like there's something else I missed
in another bug fix. I'll keep working on it.

Ian

-- Additional comment from staubach@redhat.com on 2007-07-20 11:09 EST --
I've "upgraded" back to the original autofs-5.0.1-9 which came with
F-7 so that I could get functional again.  I'd like to run the newer
code though, so...

Waiting on pins and needles...  :-)

-- Additional comment from ikent@redhat.com on 2007-07-20 11:28 EST --
(In reply to comment #14)
> Ahh .. but wait, it looks like there's something else I missed
> in another bug fix. I'll keep working on it.


Phew, false alarm.

I used to have /usr/src on a separate filesystem on my test
NFS server. I forgot I changed it to /usr (not exported) and
autofs quite rightly return EACCES when it tried to mount
/usr/src.

I'll go ahead with the commit of this change.

Ian

-- Additional comment from updates@fedoraproject.org on 2007-07-20 15:37 EST --
autofs-5.0.1-20 has been pushed to the Fedora 7 stable repository.  If problems
still persist, please make note of it in this bug report.
Comment 1 Ian Kent 2007-10-16 06:03:29 EDT
Created attachment 228501 [details]
Patch to fix handle trailing slash in quoted entry from hosts map
Comment 2 RHEL Product and Program Management 2007-10-16 06:05:07 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 errata-xmlrpc 2008-05-21 10:38:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0354.html

Note You need to log in before you can comment on or make changes to this bug.