Bug 33422 - rhnsd runs unnecessarily
Summary: rhnsd runs unnecessarily
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 17:01 UTC by Matthew Kirkwood
Modified: 2015-01-07 23:44 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 18:39:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Matthew Kirkwood 2001-03-27 17:01:31 UTC
The default install of up2date runs rhnsd unconditionally.  Given that some
people have privacy worries about the disappearance of non-anon up2date, it
would be wise to change this.

Since the RHN registratration process runs as root, it should suffice to
"chkconfig rhnsd on" (and maybe "service rhnsd start") when first
configured.

This would have saved the 7.0 fd leak embarrasment too, since signups would
have got the update before rhnsd had had a chance to run for too long.

Comment 1 Preston Brown 2001-03-27 17:54:12 UTC
We agree.  rhnsd's init script will check for the existence of 
/etc/sysconfig/rhn/systemid before starting, and rhn_register will attempt to 
start rhnsd if it is not already running after successful registration.

Comment 2 Daniel Roesen 2001-03-27 18:39:18 UTC
Heh, how opinions can change... :->

See Bug #17934

Comment 3 Preston Brown 2001-03-28 18:40:28 UTC
yes, opinions can change.

Changed in rawhide (2.4.6 and later).



Note You need to log in before you can comment on or make changes to this bug.