Bug 33508 - /etc/rc.d/init.d/sshd should use full pathname for sshd
Summary: /etc/rc.d/init.d/sshd should use full pathname for sshd
Status: CLOSED DUPLICATE of bug 33122
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: openssh   
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-27 22:47 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 22:47:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-27 22:47:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT)


/etc/rc.d/init.d/sshd should invoke sshd using its fully qualified path 
name, not just "sshd".  If you just use "sshd", then sshd cannot reload 
its config file when it receives a SIGHUP:

# kill -HUP `cat /var/run/sshd.pid`

Instead, this kills sshd.

I'm not sure which versions of the openssh-server RPM have this problem.  
My system has since been upgraded.  It definitely happened with openssh 
2.5.1p1.

Reproducible: Always
Steps to Reproduce:
1. kill -HUP `cat /var/run/sshd.pid`
2. ps uaxww|grep sshd
	

Actual Results:  You'll see that sshd is no longer running.


Expected Results:  sshd should be running.

Comment 1 Bill Nottingham 2001-03-27 23:03:24 UTC

*** This bug has been marked as a duplicate of 33122 ***


Note You need to log in before you can comment on or make changes to this bug.