Bug 33122 - /etc/rc.d/init.d/sshd kills wrong process
/etc/rc.d/init.d/sshd kills wrong process
Status: CLOSED DUPLICATE of bug 33633
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 33508 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-25 12:58 EST by Ben LaHaise
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-14 16:43:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben LaHaise 2001-03-25 12:58:31 EST
The startup script for sshd makes use of killproc to kill off sshd instead
of killing the pid listed in /var/run/sshd.pid.  This causes rather severe
unexpected behaviour when attempting to upgrade openssh remotely.
Comment 1 Bill Nottingham 2001-03-26 00:55:48 EST
killproc in 7.1 looks at pid files first. This should work better.
Comment 2 Bill Nottingham 2001-03-27 18:03:20 EST
*** Bug 33508 has been marked as a duplicate of this bug. ***
Comment 3 Pekka Savola 2001-04-14 16:43:53 EDT
Weird.  The is no resolution. Will try repen and mark duplicate of 33633.
Comment 4 Pekka Savola 2001-04-14 16:44:18 EDT

*** This bug has been marked as a duplicate of 33633 ***

Note You need to log in before you can comment on or make changes to this bug.