Bug 335861 - Cannot open 'SVN Repository Exploring' perspective
Cannot open 'SVN Repository Exploring' perspective
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-subclipse (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Robert Marcano
Fedora Extras Quality Assurance
:
Depends On: 350291
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 04:55 EDT by Stuart Campbell
Modified: 2008-08-02 19:40 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.2.4-5.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-12 19:05:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Stuart Campbell 2007-10-17 04:55:46 EDT
Description of problem:

I cannot seem to switch to the 'SVN repository exploring' perspective.

Version-Release number of selected component (if applicable):

eclipse-subclipse-1.2.2-6.fc8

eclipse-subclipse-book-1.2.2-6.fc8
eclipse-emf-xsd-2.2.2-1.fc7
eclipse-mylyn-bugzilla-2.0.0-9.fc8
eclipse-ecj-3.3.0-27.fc8
eclipse-emf-sdo-2.2.2-1.fc7
eclipse-cvs-client-3.3.0-27.fc8
eclipse-pde-runtime-3.3.0-27.fc8
eclipse-gef-sdk-3.3.0-1.fc8
eclipse-emf-standalone-2.2.2-1.fc7
eclipse-jdt-3.3.0-27.fc8
eclipse-mylyn-ide-2.0.0-9.fc8
eclipse-emf-examples-2.2.2-1.fc7
eclipse-pydev-1.3.9-1.fc8
eclipse-changelog-2.5.1-2.fc8
eclipse-pde-3.3.0-27.fc8
eclipse-mylyn-trac-2.0.0-9.fc8
eclipse-cdt-4.0.1-1.fc8
eclipse-mylyn-pde-2.0.0-9.fc8
eclipse-cdt-sdk-4.0.1-1.fc8
eclipse-rcp-3.3.0-27.fc8
eclipse-mylyn-2.0.0-9.fc8
eclipse-mylyn-java-2.0.0-9.fc8
eclipse-changelog-jdt-2.5.1-2.fc8
eclipse-emf-xsd-sdk-2.2.2-1.fc7
eclipse-emf-sdk-2.2.2-1.fc7
eclipse-checkstyle-4.0.1-9.fc8
eclipse-platform-3.3.0-27.fc8
eclipse-changelog-cdt-2.5.1-2.fc8
eclipse-emf-sdo-sdk-2.2.2-1.fc7
eclipse-gef-examples-3.3.0-1.fc8
eclipse-emf-2.2.2-1.fc7
eclipse-rpm-editor-0.1.0-10.fc8
eclipse-demos-0.0.1-2.fc8
eclipse-gef-3.3.0-1.fc8
eclipse-quickrex-3.5.0-5.fc8

How reproducible:

Everytime.

Steps to Reproduce:
1. Install (and then update) Fedora 8 test 3
2. Start Eclipse
3. Window->Open Perspective->SVN Repository Exploring
  
Actual results:

Problems opening perspective
'org.tigris.subversion.subclipse.ui.svnPerspective'

Expected results:

Open the 'SVN Repository Exploring' perspective

Additional info:
Comment 1 Derek P. Moore 2007-10-24 16:58:23 EDT
I have always had this same problem with Fedora 7.
Comment 2 Robert Marcano 2007-10-25 08:12:37 EDT
Can both try with the latest release available 1.4.x and remove beforehand the
directory $HOME/.eclipse
Comment 3 Stuart Campbell 2007-10-25 12:25:31 EDT
I cannot seem to find a version 1.4.x anywhere?  Where do I get it from ?
Comment 4 Robert Marcano 2007-10-25 12:35:25 EDT
oops my mistake.. it is 1.2.4 not 1.4, do not forget to remove beforehand the
directory $HOME/.eclipse, some caching is done there that i have still not been
able to workaround
Comment 5 Robert Marcano 2007-10-25 12:47:01 EDT
1.2.4 is not tagged for fedora 8 yet.. it looks like I have to wait for bug
#350291 to rebuild it again
Comment 6 Jens Petersen 2007-10-25 20:53:47 EDT
I guess this the same problem that stops one opening an svn project too?

Removing ~/.eclipse does not help for me.

I wonder if this should be proposed as an F8Blocker.
Comment 7 Stuart Campbell 2007-11-07 05:21:13 EST
I have just done a clean install of RC3 (with a new user and home directory) and
I still get the same problem.
Comment 8 Stuart Campbell 2007-11-07 05:51:16 EST
I have just downloaded 1.2.4-3 from koji and that seems to have fixed the problem.
Comment 9 Jens Petersen 2007-11-07 21:58:14 EST
Robert, are you going to push an update for F8 soon?
Comment 10 Fedora Update System 2007-11-12 19:05:44 EST
eclipse-subclipse-1.2.4-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.