Bug 33595 - After upgrading to rpm-4.0.2-6x, snmd and snmpwalk give error in loading shared libraries
Summary: After upgrading to rpm-4.0.2-6x, snmd and snmpwalk give error in loading shar...
Status: CLOSED DUPLICATE of bug 33085
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-28 14:10 UTC by Alessandro Villani
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-28 17:15:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alessandro Villani 2001-03-28 14:10:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-3 i686)


After I upgraded the rpm packages from v:3 to v:4, snmpd and snmpwalk
stopped to work.
When I give the command snmpwalk I get the message:
snmpwalk: error in loading shared libraries: /usr/lib/librpm.so.0:
undefined symbol: fdio
The same messages show up when snmpd start:
snmpd: : error in loading shared libraries: /usr/lib/librpm.so.0: undefined
symbol: fdio



Reproducible: Always
Steps to Reproduce:
1. snmpwalk
2. 
3.
	

Actual Results:  The program dosn't start:
snmpwalk: error in loading shared libraries: /usr/lib/librpm.so.0:
undefined symbol: fdio

The current version of rpm is 4.0.2-6x, and the ersion of ucd-snmp is
4.1.1-2

Comment 1 Roberto Mansoni 2001-03-28 17:14:57 UTC
I did an "rpm --rebuild ucd-snmp-4.1.1-2.src.rpm" and the snmpwalk problem
went away, but I got the following message:

+ install -m 0644 libsnmp.a /var/tmp/ucd-snmp-root/usr/lib
install: cannot create regular file `/var/tmp/ucd-snmp-root/usr/lib': No such
file or directory
error: Bad exit status from /var/tmp/rpm-tmp.94515 (%install)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.94515 (%install)


Comment 2 Bill Nottingham 2001-03-28 17:20:57 UTC

*** This bug has been marked as a duplicate of 33085 ***


Note You need to log in before you can comment on or make changes to this bug.