Bug 336601 - bind segfaults when incorrectly configured to use dbus
bind segfaults when incorrectly configured to use dbus
Status: CLOSED DUPLICATE of bug 339191
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
high Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-17 15:32 EDT by Peter Jones
Modified: 2013-04-30 19:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-22 04:24:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
fix va_start calls that don't call va_end (1.92 KB, patch)
2007-10-17 15:32 EDT, Peter Jones
no flags Details | Diff
gdb log (5.38 KB, text/plain)
2007-10-20 15:09 EDT, Milan Broz
no flags Details

  None (edit)
Description Peter Jones 2007-10-17 15:32:10 EDT
Description of problem: In certain situations when bind is configured to use
dbus, but the other dbus client it would be communicating with isn't present,
bind will segfault.

Version-Release number of selected component (if applicable):
bind-9.5.0-14.a6.fc8

How reproducible:
Happens pretty much every time if the start order is wrong (which I think is
generally true if you've upgraded) and it's configured to use dbus.

Steps to Reproduce:
1. service bind start
2.
3.
  
Actual results:
Log messages that say:
Oct 17 13:58:47 localhost named[29213]: dbus_svc_add_filter failed
Oct 17 13:58:47 localhost named[29213]: dbus_mgr initialization failed. D-BUS
service is disabled.
Oct 17 13:58:47 localhost named[29213]: running
Oct 17 13:58:47 localhost kernel: named[29215]: segfault at 348c7da0 eip
0044c1ff esp b74e9240 error 6

Expected results:
first 3 log messages, then no segfault.

Additional info:
This actually seems to be caused by the error logging functions in bind's dbus
initialization code, which call va_start but not always va_end.  I've attached a
patch which fixes the problem.
Comment 1 Peter Jones 2007-10-17 15:32:10 EDT
Created attachment 230311 [details]
fix va_start calls that don't call va_end
Comment 2 Adam Tkac 2007-10-18 08:35:12 EDT
I'm not sure if your crash is caused by missing va_end but patch is correct.
I've removed statement which patches idnkit because this part is already
obsolete and We're using libidn for IDN support. Thanks for patch.

Adam
Comment 3 Adam Tkac 2007-10-19 04:43:46 EDT
I've got next report which will be related to this. Could you test updated
package (http://kojiweb.fedoraproject.org/koji/taskinfo?taskID=202749) ASAP,
please? This issue should be fixed in F8 final.
Comment 4 Milan Broz 2007-10-20 15:09:43 EDT
Created attachment 233521 [details]
gdb log

I see this after upgrading too, even with new build
# rpm -q bind dbus
bind-9.5.0-15.1.a6.fc8
dbus-1.1.2-7.fc8

See attached gdb session log.
Comment 5 Adam Tkac 2007-10-22 04:24:58 EDT

*** This bug has been marked as a duplicate of 339191 ***

Note You need to log in before you can comment on or make changes to this bug.